summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-05-11 00:08:44 +0200
committerSebastian Pipping <sping@gentoo.org>2019-05-11 00:26:27 +0200
commitda5c9b70bf178b68f852270718ef67dcbbfcb0c7 (patch)
tree0ca2fb6e0e2c84748372bd3ab1dcd9d5721af27a /app-emulation
parentapp-emulation/docker-compose: Set maintainer (diff)
downloadgentoo-da5c9b70bf178b68f852270718ef67dcbbfcb0c7.tar.gz
gentoo-da5c9b70bf178b68f852270718ef67dcbbfcb0c7.tar.bz2
gentoo-da5c9b70bf178b68f852270718ef67dcbbfcb0c7.zip
app-emulation/docker-compose: Fix dependencies
This unblocks system-wide updates of e.g. - dev-python/jsonschema-3.0.1 - dev-python/pyyaml-5.1 - dev-python/texttable-1.6.1 Closes: https://bugs.gentoo.org/681002 Bug: https://bugs.gentoo.org/679968 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.65, Repoman-2.3.12
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild66
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch58
2 files changed, 124 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild b/app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild
new file mode 100644
index 000000000000..df1a0e87a651
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+
+S="${WORKDIR}/compose-${PV}"
+
+PATCHES=(
+ # Bug #679968 -- https://bugs.gentoo.org/679968
+ # Bug #681002 -- https://bugs.gentoo.org/681002
+ "${FILESDIR}"/${PN}-1.23.2-setup-py.patch
+)
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch
new file mode 100644
index 000000000000..193ece1c09f9
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch
@@ -0,0 +1,58 @@
+From 15b1ac5bfeb0ca2a8524dae10db7573b4efacba9 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Fri, 10 May 2019 23:54:14 +0200
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 22dafdb..00167ce 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,16 +30,16 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 0.7',
+- 'PyYAML >= 3.10, < 4',
+- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
+- 'texttable >= 0.9.0, < 0.10',
+- 'websocket-client >= 0.32.0, < 1.0',
+- 'docker >= 3.6.0, < 4.0',
+- 'dockerpty >= 0.4.1, < 0.5',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 3',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker >= 3.6.0',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
+ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
+ ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.21.0
+