summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-15 22:40:23 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-15 22:40:23 +0900
commitb1bd9b45d1d5217a547f0d119b6162e0c3280282 (patch)
tree0c223a229d049f53d2a6cec2a5dd6cb96907fb8c /app-i18n/ibus-hangul
parentgnome-base/gdm: bump to 41.0 with patchset (diff)
downloadgentoo-b1bd9b45d1d5217a547f0d119b6162e0c3280282.tar.gz
gentoo-b1bd9b45d1d5217a547f0d119b6162e0c3280282.tar.bz2
gentoo-b1bd9b45d1d5217a547f0d119b6162e0c3280282.zip
app-i18n/ibus-hangul: fix tests
Closes: https://bugs.gentoo.org/740466 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-hangul')
-rw-r--r--app-i18n/ibus-hangul/files/ibus-hangul-test.patch20
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild14
2 files changed, 32 insertions, 2 deletions
diff --git a/app-i18n/ibus-hangul/files/ibus-hangul-test.patch b/app-i18n/ibus-hangul/files/ibus-hangul-test.patch
new file mode 100644
index 000000000000..7a6ef479f0ee
--- /dev/null
+++ b/app-i18n/ibus-hangul/files/ibus-hangul-test.patch
@@ -0,0 +1,20 @@
+--- a/tests/ibus-hangul.c
++++ b/tests/ibus-hangul.c
+@@ -261,6 +261,7 @@
+ G_CALLBACK (window_inserted_text_cb), entry);
+ gtk_container_add (GTK_CONTAINER (window), entry);
+ gtk_widget_show_all (window);
++ gtk_window_present (window);
+ }
+
+ static void
+--- a/tests/runtest
++++ b/tests/runtest
+@@ -7,7 +7,6 @@
+ : ${DISABLE_GUI_TESTS:=''}
+
+ ibus-daemon --xim --panel disable --config disable &
+-sleep 30
+
+ tst=$1
+
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
index 4d13e3d9b116..e8b64f68faad 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_COMPAT=( python3_{8,9} )
-inherit gnome2-utils python-single-r1 xdg
+inherit gnome2-utils python-single-r1 xdg virtualx
DESCRIPTION="Korean Hangul engine for IBus"
HOMEPAGE="https://github.com/libhangul/ibus-hangul/wiki"
@@ -27,12 +27,22 @@ DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+
src_configure() {
econf \
$(use_enable nls) \
--with-python=${EPYTHON}
}
+src_test() {
+ "${BROOT}"${GLIB_COMPILE_SCHEMAS} --allow-any-name "${S}"/data || die
+
+ export GSETTINGS_BACKEND="memory"
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx default
+}
+
pkg_preinst() {
xdg_pkg_preinst
gnome2_schemas_savelist