summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-06-03 11:41:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-06-03 11:41:33 +0900
commitbd1b6642aa58a218d78d722d7b43b0397de16c93 (patch)
treef1752ce508ebc65b9b6ce97557c1082228ce1c7a /app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
parentapp-i18n/uim-tomoe-gtk: fix tests with >=dev-lang/perl-5.26 (diff)
downloadgentoo-bd1b6642aa58a218d78d722d7b43b0397de16c93.tar.gz
gentoo-bd1b6642aa58a218d78d722d7b43b0397de16c93.tar.bz2
gentoo-bd1b6642aa58a218d78d722d7b43b0397de16c93.zip
app-i18n/ibus-typing-booster: new upstream release
Closes: https://bugs.gentoo.org/656844 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild')
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
new file mode 100644
index 000000000000..b4bb8048b30d
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"