summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:17:47 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:17:47 +0100
commitb964acf0050b843f4af23787198a5b179b493fe3 (patch)
tree4102d83e6d7d8bbd1a0172708384b66b5cf68b4f /app-misc/hivex
parentapp-misc/egads: disable static libs (diff)
downloadgentoo-b964acf0050b843f4af23787198a5b179b493fe3.tar.gz
gentoo-b964acf0050b843f4af23787198a5b179b493fe3.tar.bz2
gentoo-b964acf0050b843f4af23787198a5b179b493fe3.zip
app-misc/hivex: disable static libs
Closes: https://bugs.gentoo.org/726640 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/hivex-1.3.14.ebuild5
-rw-r--r--app-misc/hivex/hivex-1.3.18.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/app-misc/hivex/hivex-1.3.14.ebuild b/app-misc/hivex/hivex-1.3.14.ebuild
index 9f629900febb..cd4e1de9670b 100644
--- a/app-misc/hivex/hivex-1.3.14.ebuild
+++ b/app-misc/hivex/hivex-1.3.14.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="ocaml readline +perl python test static-libs ruby"
+IUSE="ocaml readline +perl python test ruby"
RDEPEND="
virtual/libiconv
@@ -82,6 +82,7 @@ src_configure() {
--disable-ruby
$(use_enable python)
--disable-rpath
+ --disable-static
)
econf ${myeconfargs[@]}
@@ -102,4 +103,6 @@ src_install() {
if use perl; then
perl_delete_localpod
fi
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/app-misc/hivex/hivex-1.3.18.ebuild b/app-misc/hivex/hivex-1.3.18.ebuild
index dad58992eb7d..568b03b92bd9 100644
--- a/app-misc/hivex/hivex-1.3.18.ebuild
+++ b/app-misc/hivex/hivex-1.3.18.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline +perl python test static-libs ruby"
+IUSE="ocaml readline +perl python test ruby"
RDEPEND="
virtual/libiconv
@@ -82,6 +82,7 @@ src_configure() {
--disable-ruby
$(use_enable python)
--disable-rpath
+ --disable-static
)
econf ${myeconfargs[@]}
@@ -105,4 +106,6 @@ src_install() {
if use perl; then
perl_delete_localpod
fi
+
+ find "${ED}" -name '*.la' -delete || die
}