summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-07-18 19:18:38 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-07-18 19:18:38 -0700
commit4ba06b5ba1fef6cbd2d1c120f84b09c06932a13f (patch)
tree4274b6d4d8d52afce7cb0b414e2f91f87ff57999 /app-shells
parentsys-process/glances: don't install docs by default (diff)
downloadgentoo-4ba06b5ba1fef6cbd2d1c120f84b09c06932a13f.tar.gz
gentoo-4ba06b5ba1fef6cbd2d1c120f84b09c06932a13f.tar.bz2
gentoo-4ba06b5ba1fef6cbd2d1c120f84b09c06932a13f.zip
app-shells/fish: fix 'printf "%o"' handling on ppc
Backport as a patch, that is already upstream https://github.com/fish-shell/fish-shell/pull/4444 Run tests with -j1 and be verbose Run tests only if fish is already installed Reported-by: Sergei Trofimovich <slyfox@gentoo.org> Bug: https://bugs.gentoo.org/656246 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/files/fish-2.7.1-fix-printf-o-handling-on-ppc.patch12
-rw-r--r--app-shells/fish/fish-2.7.1.ebuild8
2 files changed, 19 insertions, 1 deletions
diff --git a/app-shells/fish/files/fish-2.7.1-fix-printf-o-handling-on-ppc.patch b/app-shells/fish/files/fish-2.7.1-fix-printf-o-handling-on-ppc.patch
new file mode 100644
index 000000000000..4d3d79ae6a53
--- /dev/null
+++ b/app-shells/fish/files/fish-2.7.1-fix-printf-o-handling-on-ppc.patch
@@ -0,0 +1,12 @@
+diff --git a/src/builtin_printf.cpp b/src/builtin_printf.cpp
+index 8595120d5..24cf9a9e1 100644
+--- a/src/builtin_printf.cpp
++++ b/src/builtin_printf.cpp
+@@ -444,6 +444,7 @@ void builtin_printf_state_t::print_direc(const wchar_t *start, size_t length, wc
+ case L'X':
+ case L'd':
+ case L'i':
++ case L'o':
+ case L'u': {
+ fmt.append(L"ll");
+ break;
diff --git a/app-shells/fish/fish-2.7.1.ebuild b/app-shells/fish/fish-2.7.1.ebuild
index 657ee7b3e84c..06afa49de51f 100644
--- a/app-shells/fish/fish-2.7.1.ebuild
+++ b/app-shells/fish/fish-2.7.1.ebuild
@@ -27,6 +27,8 @@ DEPEND="
test? ( dev-tcltk/expect )
"
+PATCHES=( "${FILESDIR}/${P}-fix-printf-o-handling-on-ppc.patch" )
+
S="${WORKDIR}/${MY_P}"
src_configure() {
@@ -48,7 +50,11 @@ src_install() {
}
src_test() {
- emake V=1 test
+ if has_version ~${CATEGORY}/${P} ; then
+ emake -j1 V=1 SHOW_INTERACTIVE_LOG=1 test
+ else
+ ewarn "Some tests only work when the package is already installed"
+ fi
}
pkg_postinst() {