summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pdftk/pdftk-2.02.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pdftk/pdftk-2.02.ebuild')
-rw-r--r--app-text/pdftk/pdftk-2.02.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/pdftk/pdftk-2.02.ebuild b/app-text/pdftk/pdftk-2.02.ebuild
new file mode 100644
index 000000000000..eeb47b04d20a
--- /dev/null
+++ b/app-text/pdftk/pdftk-2.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/"
+SRC_URI="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux"
+
+DEPEND="sys-devel/gcc[gcj]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-dist/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ # Settings by java-config break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+
+ # Parallel make fails; confirmed, still not fixed in version 2.02.
+ emake -j1 -f "${S}"/Makefile.Debian || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ doman ../pdftk.1
+ dohtml ../pdftk.1.html
+}