summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdftk/pdftk-2.02.ebuild')
-rw-r--r--app-text/pdftk/pdftk-2.02.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/pdftk/pdftk-2.02.ebuild b/app-text/pdftk/pdftk-2.02.ebuild
new file mode 100644
index 000000000000..eeb47b04d20a
--- /dev/null
+++ b/app-text/pdftk/pdftk-2.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/"
+SRC_URI="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux"
+
+DEPEND="sys-devel/gcc[gcj]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-dist/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ # Settings by java-config break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+
+ # Parallel make fails; confirmed, still not fixed in version 2.02.
+ emake -j1 -f "${S}"/Makefile.Debian || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ doman ../pdftk.1
+ dohtml ../pdftk.1.html
+}