summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 18:37:46 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 20:16:07 +0100
commit6669f519744d5e777f758f156c6242b6dd64f7e1 (patch)
tree084e70c86940304f90757b47139240d3b19dd890 /app-text/zathura-djvu
parentapp-text/zathura-cb: [QA] Port to git-r3 (diff)
downloadgentoo-6669f519744d5e777f758f156c6242b6dd64f7e1.tar.gz
gentoo-6669f519744d5e777f758f156c6242b6dd64f7e1.tar.bz2
gentoo-6669f519744d5e777f758f156c6242b6dd64f7e1.zip
app-text/zathura-djvu: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/zathura-djvu')
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild24
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild20
-rw-r--r--app-text/zathura-djvu/zathura-djvu-9999.ebuild24
3 files changed, 32 insertions, 36 deletions
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild
index a73fd153f5a2..b02dee3dc614 100644
--- a/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="DjVu plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="amd64 arm x86"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/djvu-3.5.24-r1:=
@@ -30,7 +28,7 @@ RDEPEND=">=app-text/djvu-3.5.24-r1:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild
index e6ef493fc4ff..2de3b88232f7 100644
--- a/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild
@@ -4,21 +4,21 @@
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="DjVu plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="amd64 arm x86"
-fi
IUSE=""
RDEPEND=">=app-text/djvu-3.5.24-r1:=
@@ -28,7 +28,7 @@ RDEPEND=">=app-text/djvu-3.5.24-r1:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
diff --git a/app-text/zathura-djvu/zathura-djvu-9999.ebuild b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
index 0cec0327dc88..810861d8da93 100644
--- a/app-text/zathura-djvu/zathura-djvu-9999.ebuild
+++ b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="DjVu plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="~amd64 ~arm ~x86"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/djvu-3.5.24-r1:=
@@ -30,7 +28,7 @@ RDEPEND=">=app-text/djvu-3.5.24-r1:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"