summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-26 01:04:03 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-26 01:05:15 -0400
commit5fff8e01b621e5fcc755f93161ad0a4ad598d62b (patch)
tree690a62c5991e77529a7735cd3ab72b3fd4049b5f /app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild
parentnet-irc/inspircd: bump to vn. 2.0.21 (diff)
downloadgentoo-5fff8e01b621e5fcc755f93161ad0a4ad598d62b.tar.gz
gentoo-5fff8e01b621e5fcc755f93161ad0a4ad598d62b.tar.bz2
gentoo-5fff8e01b621e5fcc755f93161ad0a4ad598d62b.zip
app-vim/vim-rest-console: initial import
Diffstat (limited to 'app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild')
-rw-r--r--app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild b/app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild
new file mode 100644
index 000000000000..6c8b9acf4879
--- /dev/null
+++ b/app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a REST console for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=5182 https://github.com/diepm/vim-rest-console"
+SRC_URI="https://github.com/diepm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="net-misc/curl"
+
+src_prepare() {
+ rm *.md *.json *.rest || die
+}