summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/vimpress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/vimpress')
-rw-r--r--app-vim/vimpress/Manifest2
-rw-r--r--app-vim/vimpress/metadata.xml5
-rw-r--r--app-vim/vimpress/vimpress-2.1.5.ebuild30
-rw-r--r--app-vim/vimpress/vimpress-3.2.0.ebuild21
4 files changed, 58 insertions, 0 deletions
diff --git a/app-vim/vimpress/Manifest b/app-vim/vimpress/Manifest
new file mode 100644
index 000000000000..58ee4a9d84d9
--- /dev/null
+++ b/app-vim/vimpress/Manifest
@@ -0,0 +1,2 @@
+DIST vimpress-2.1.5.tar.gz 11341 SHA256 2c08753b0a022f74232b895fe73146f91795585bf2102f425c2b7773ce6d1071 SHA512 34bbf205ecc92dee4ab897bd3d3d34fc808acdd0a60eb3c3e763056aa2c0487d9423a1e5e9fe252d0da5a8ecaaa7a64a3dc406bea472942a35ada4875b30db47 WHIRLPOOL 8877dcd0ead65b5c8d0019161c46d8e846bdffb606211373de763ab2b758c814159f0ed5ef16309facd57c3c07a3b76a729f7b6a80aaadf46d38748cce82af79
+DIST vimpress-3.2.0.tar.bz2 11456 SHA256 27371c8279ee9a4f656ffa245784979bcedc8544ff68729b3abf185d172ebe39 SHA512 793f013ccc42180e095c2e8cc847719479418cc0b184688924520f0782ee27e99a7fc64e44bf5c25f2a720b19dd813a4756fc90b87c18e13766ef0ce7772334a WHIRLPOOL 63ef626d59babcdad3c9600db49d15801d1365617384d07124acb7272b9cf26e63a552710c0e3d4b23e7fe3b63f84dbe08ffbae5c2d573c8d7c036aff6180e67
diff --git a/app-vim/vimpress/metadata.xml b/app-vim/vimpress/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/vimpress/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/vimpress/vimpress-2.1.5.ebuild b/app-vim/vimpress/vimpress-2.1.5.ebuild
new file mode 100644
index 000000000000..52a001ee3ed6
--- /dev/null
+++ b/app-vim/vimpress/vimpress-2.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="VimRepress"
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ dev-python/markdown"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm README || die
+}
diff --git a/app-vim/vimpress/vimpress-3.2.0.ebuild b/app-vim/vimpress/vimpress-3.2.0.ebuild
new file mode 100644
index 000000000000..7d9e88b691d7
--- /dev/null
+++ b/app-vim/vimpress/vimpress-3.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ dev-python/markdown"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"