summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-24 19:54:05 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-24 20:09:51 -0400
commitb5767ffb9d191fb5c88f8c7798138e5af0244be7 (patch)
tree290bd08e3ba71ec35408c6f25999845c5f341719 /app-vim
parentapp-vim/airline: version bump to 0.9 (diff)
downloadgentoo-b5767ffb9d191fb5c88f8c7798138e5af0244be7.tar.gz
gentoo-b5767ffb9d191fb5c88f8c7798138e5af0244be7.tar.bz2
gentoo-b5767ffb9d191fb5c88f8c7798138e5af0244be7.zip
app-vim/vimtex: version bump to 20180324
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimtex/Manifest1
-rw-r--r--app-vim/vimtex/vimtex-20180324.ebuild36
-rw-r--r--app-vim/vimtex/vimtex-99999999.ebuild36
3 files changed, 73 insertions, 0 deletions
diff --git a/app-vim/vimtex/Manifest b/app-vim/vimtex/Manifest
index ab1c92910102..a943ac802bd6 100644
--- a/app-vim/vimtex/Manifest
+++ b/app-vim/vimtex/Manifest
@@ -1 +1,2 @@
DIST vimtex-20160324.tar.bz2 95040 BLAKE2B a6ea2c0ace2aea108545347e0dd624dd838005d752d3e823d230f6fff04ba37f82c98ff472b06b6b5b58a8481824ba1ffad3c756d50a96ea9c79e8e506783131 SHA512 0c0d2a95f3b62239f47113f5b8876728d6d9fddf7e526477e92ef1f09317cb607ddd3b2aa07f6e8bebd357308adf21e4c353795952dc30372b493963bd0554ff
+DIST vimtex-20180324.tar.gz 684092 BLAKE2B 4472c9e62c5795b621a9230fbd7ea1f018c6df440f58065e7b439f64ae67f4064b158094c8d0b8a6eba6202bc9e6729b792fced02ea9deeaf400f0240537795d SHA512 59038aff6ec761a9f73db7d638a70e9ea5ba4d3ef4bd9283f3a62beb5e412f1a3c752dd0d739dc4c9c5e33e4a00a84a91da56e8fea2b8113b7ef73d219997409
diff --git a/app-vim/vimtex/vimtex-20180324.ebuild b/app-vim/vimtex/vimtex-20180324.ebuild
new file mode 100644
index 000000000000..d4031034c014
--- /dev/null
+++ b/app-vim/vimtex/vimtex-20180324.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
+ SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin
+ virtual/latex-base
+ dev-tex/latexmk
+"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r *.md media test || die
+}
diff --git a/app-vim/vimtex/vimtex-99999999.ebuild b/app-vim/vimtex/vimtex-99999999.ebuild
new file mode 100644
index 000000000000..d4031034c014
--- /dev/null
+++ b/app-vim/vimtex/vimtex-99999999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
+ SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin
+ virtual/latex-base
+ dev-tex/latexmk
+"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r *.md media test || die
+}