summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-22 11:20:42 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-23 23:42:57 -0400
commitd394ceeb7b97d8883779c87042785ba55f277788 (patch)
tree2d065bba3a259b9514e6a6f2e14bedb9e4f7d078 /dev-cpp/pangomm
parentdev-cpp/pangomm: Version bump to 2.46.3 (diff)
downloadgentoo-d394ceeb7b97d8883779c87042785ba55f277788.tar.gz
gentoo-d394ceeb7b97d8883779c87042785ba55f277788.tar.bz2
gentoo-d394ceeb7b97d8883779c87042785ba55f277788.zip
dev-cpp/pangomm: Version bump to 2.50.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/pangomm')
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/pangomm-2.50.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
index 7d601652122c..cf8ce199c6e4 100644
--- a/dev-cpp/pangomm/Manifest
+++ b/dev-cpp/pangomm/Manifest
@@ -1,3 +1,4 @@
DIST pangomm-2.46.2.tar.xz 674892 BLAKE2B ac86ef1a229dca29eeb41d3751128bed56d182cecfc6655a478b5a7473d10782fe98cdfee4db6f5afbfe9fb8adbf0e646004aa69c4c4058191078c7b5716434b SHA512 79cad137ec9f22e57a177332df6c6e735aa3baf81df36fc706e81e7a89f23ce3179337507388f65a0d0a74733990dc3547c50243a4559dfd0bb065b1828c0474
DIST pangomm-2.46.3.tar.xz 674428 BLAKE2B 241b902e65ebb2cc213f479832503f07daad736e168ad7e841f3a22e8640e0365167cb29122cd1bf7080bf7b283ddb92aa71aee9731ea878a1ef26f88c3796c6 SHA512 c0925f295b372bca7b5ede28476ed00e691911e041632969e5e4c30fcf338bac069ba031d4f48601877524b90af47f5238e444e2de7501f1ff25dcda9dd9a9c8
DIST pangomm-2.50.0.tar.xz 753592 BLAKE2B 0db7d43fe2d23e4cfc2b083a4d832c7875c63a261c6b10c62898bf428351ea7d8d05136a46f9498cdb78c51a0223ca988cbc3481041b997dc5d6a9f16f02ec91 SHA512 844850db93b8c4dab19dd364e674ee3d61b2fcb8e020ab3d314f240065ee17aeceea21e9ddc438a7d09d56410e3f82147a57425f76bb01e26d82872934269477
+DIST pangomm-2.50.1.tar.xz 754608 BLAKE2B 3581db044e95fb78e2f8e67868735d6626d052099076c9b46668a255bb8df2cbc152dbaf730bfe2a3b47610a1a4e1903d83950d303d59913d9ff123a882db772 SHA512 bffc55eedc4f278480a74afcf119b79a295bf5775123f582746ba425e19e2690d627baa9a9813b70db9e063db7efe959f365567dd7bcbc1fc862212ba8225a98
diff --git a/dev-cpp/pangomm/pangomm-2.50.1.ebuild b/dev-cpp/pangomm/pangomm-2.50.1.ebuild
new file mode 100644
index 000000000000..b291b42d21dc
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.50.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/pangomm"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="gtk-doc"
+
+RDEPEND="
+ >=dev-cpp/cairomm-1.16.0:1.16[gtk-doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.68.0:2.68[gtk-doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-3:3[gtk-doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.49.4[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? (
+ >=dev-cpp/mm-common-1.0.4
+ app-doc/doxygen[dot]
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=false
+ $(meson_native_use_bool gtk-doc build-documentation)
+ )
+ meson_src_configure
+}