summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 11:12:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 13:24:04 +0100
commitce3d16e1f808744400f0afd2bcca9b883a5a02ea (patch)
tree66a0b2a2625c5bda12e8b0e5d7a9d0e3f8244fe1 /dev-cpp
parentdev-db/mysql-connector-c: Switch to cmake.eclass, skel.ebuild order (diff)
downloadgentoo-ce3d16e1f808744400f0afd2bcca9b883a5a02ea.tar.gz
gentoo-ce3d16e1f808744400f0afd2bcca9b883a5a02ea.tar.bz2
gentoo-ce3d16e1f808744400f0afd2bcca9b883a5a02ea.zip
dev-cpp/gflags: Switch to cmake.eclass, use https
Follow-up to commit 932dc78d1c7fff951f55c2ca509634e9d9e304cb Closes: https://bugs.gentoo.org/770520 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gflags/gflags-2.2.1-r1.ebuild7
-rw-r--r--dev-cpp/gflags/gflags-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-cpp/gflags/gflags-2.2.1-r1.ebuild b/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
index 3a7f4b44bc0e..4ee23a61cae4 100644
--- a/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
+++ b/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]]; then
@@ -14,7 +15,7 @@ else
fi
DESCRIPTION="Google's C++ argument parsing library"
-HOMEPAGE="http://gflags.github.io/gflags/"
+HOMEPAGE="https://gflags.github.io/gflags/"
LICENSE="BSD"
SLOT="0/2.2"
@@ -32,5 +33,5 @@ multilib_src_configure() {
# >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
-DREGISTER_INSTALL_PREFIX=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-cpp/gflags/gflags-9999.ebuild b/dev-cpp/gflags/gflags-9999.ebuild
index e8121a0281aa..6aa92ecf5e55 100644
--- a/dev-cpp/gflags/gflags-9999.ebuild
+++ b/dev-cpp/gflags/gflags-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]]; then
@@ -14,7 +15,7 @@ else
fi
DESCRIPTION="Google's C++ argument parsing library"
-HOMEPAGE="http://gflags.github.io/gflags/"
+HOMEPAGE="https://gflags.github.io/gflags/"
LICENSE="BSD"
SLOT="0/2.2"
@@ -32,5 +33,5 @@ multilib_src_configure() {
# >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
-DREGISTER_INSTALL_PREFIX=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}