summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/innotop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/innotop')
-rw-r--r--dev-db/innotop/Manifest2
-rw-r--r--dev-db/innotop/innotop-1.9.0-r1.ebuild26
-rw-r--r--dev-db/innotop/innotop-1.9.1.ebuild26
-rw-r--r--dev-db/innotop/metadata.xml10
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/innotop/Manifest b/dev-db/innotop/Manifest
new file mode 100644
index 000000000000..6ba004e157bc
--- /dev/null
+++ b/dev-db/innotop/Manifest
@@ -0,0 +1,2 @@
+DIST innotop-1.9.0.tar.gz 143179 SHA256 bc2669ea88fb728c6c4ed9c695c4d0b7b9ae5df0f158ef23e8853694bf4f240a SHA512 a3fe26b7e9e4a4608f6ef68e8cfefca080fd5799cc7780ffadd0b6bd0a0cfd035561bf6c10436f556b8fc79726304cae408343a231a57d02c74e3bd29b941a17 WHIRLPOOL 76226828f8c91608b03d49802cc082a77b552f7a482ab2186e71a4f9fb56662d17d4ee04c5187df78ca68a733ca4a710b3d6156e0b028375576c8abb9b7effd8
+DIST innotop-1.9.1.tar.gz 147677 SHA256 117e5af58a83af79b6cf99877b25b1479197597be5a7d51b245a0ad9c69f4d3d SHA512 5c19891fc8df2cbf15f0df1af68501624ccb9d79c22a786e3a5fa4aa527be964392131da095a529f628c50528b196070f35009a49c9a87ae9f8bb2f4062e5ab5 WHIRLPOOL b06b4c720333f433408d3f97355ad319aa3897bffa3f71da18462eb74e1d2065a60a0e91f55c26f37bb624530e18cf3e9acf4fdf7bb245e8555987eab3dee617
diff --git a/dev-db/innotop/innotop-1.9.0-r1.ebuild b/dev-db/innotop/innotop-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..a5f4aa4b2860
--- /dev/null
+++ b/dev-db/innotop/innotop-1.9.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="innotop - A text-mode MySQL and InnoDB monitor like mytop, but with many more features"
+HOMEPAGE="http://code.google.com/p/innotop/"
+SRC_URI="http://innotop.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-perl/DBD-mysql
+ dev-perl/TermReadKey
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Time-HiRes"
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+}
diff --git a/dev-db/innotop/innotop-1.9.1.ebuild b/dev-db/innotop/innotop-1.9.1.ebuild
new file mode 100644
index 000000000000..a26e025ee205
--- /dev/null
+++ b/dev-db/innotop/innotop-1.9.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="innotop - A text-mode MySQL and InnoDB monitor like mytop, but with many more features"
+HOMEPAGE="http://code.google.com/p/innotop/"
+SRC_URI="http://innotop.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-perl/DBD-mysql
+ dev-perl/TermReadKey
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Time-HiRes"
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+}
diff --git a/dev-db/innotop/metadata.xml b/dev-db/innotop/metadata.xml
new file mode 100644
index 000000000000..44b249080ca5
--- /dev/null
+++ b/dev-db/innotop/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mysql</herd>
+ <longdescription>innotop - A text-mode MySQL and InnoDB monitor like mytop,
+but with many more features</longdescription>
+ <upstream>
+ <remote-id type="google-code">innotop</remote-id>
+ </upstream>
+</pkgmetadata>