summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-01-27 13:51:39 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-01-27 13:52:24 -0100
commit3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2 (patch)
tree69187b2d47edf9d3836775bc96f5a42f9b021d67 /dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild
parentnet-irc/znc: sync live ebuild with latest release (diff)
downloadgentoo-3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2.tar.gz
gentoo-3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2.tar.bz2
gentoo-3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2.zip
dev-db/phpmyadmin: security bump to release 4.8.5.
This release addresses advisories PMASA-2019-1 and PMASA-2019-2. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild')
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild
new file mode 100644
index 000000000000..b0e6be3d92ed
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}