summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-10-20 10:42:07 -0400
committerBrian Evans <grknight@gentoo.org>2015-10-20 10:52:30 -0400
commite93c3b2c05c3bda4f115c260531d9942f98ba39d (patch)
tree71d80046f840553b4df343bba8be90edb0524133 /dev-db
parentdev-db/mysql: Add LibreSSL support (diff)
downloadgentoo-e93c3b2c05c3bda4f115c260531d9942f98ba39d.tar.gz
gentoo-e93c3b2c05c3bda4f115c260531d9942f98ba39d.tar.bz2
gentoo-e93c3b2c05c3bda4f115c260531d9942f98ba39d.zip
dev-db/mysql-cluster: Add LibreSSL support
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql-cluster/metadata.xml7
-rw-r--r--dev-db/mysql-cluster/mysql-cluster-7.3.8.ebuild8
-rw-r--r--dev-db/mysql-cluster/mysql-cluster-7.3.9-r1.ebuild8
3 files changed, 23 insertions, 0 deletions
diff --git a/dev-db/mysql-cluster/metadata.xml b/dev-db/mysql-cluster/metadata.xml
index 0fd723f94d87..3e4bee60e527 100644
--- a/dev-db/mysql-cluster/metadata.xml
+++ b/dev-db/mysql-cluster/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>mysql</herd>
+ <maintainer restrict="dev-db/mysql[libressl]">
+ <email>hasufell@gentoo.org</email>
+ <description>Libressl issues. Only assign if it's a direct Libressl issue. Do not directly assign for anything else.</description>
+ </maintainer>
<use>
<flag name='cluster'>Add support for NDB clustering</flag>
<flag name='community'>Enables the community features from upstream.</flag>
@@ -9,10 +13,13 @@
<flag name='extraengine'>Add support for alternative storage engines (Archive, CSV, Blackhole, Federated(X), Partition)</flag>
<flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations.</flag>
<flag name='latin1'>Use LATIN1 encoding instead of UTF8</flag>
+ <flag name='libressl'>Enable SSL connections and crypto functions using <pkg>dev-libs/libressl</pkg></flag>
+ <flag name='openssl'>Enable SSL connections and crypto functions using <pkg>dev-libs/openssl</pkg></flag>
<flag name='max-idx-128'>Raise the max index per table limit from 64 to 128</flag>
<flag name='minimal'>Install client programs only, no server</flag>
<flag name='profiling'>Add support for statement profiling (requires USE=community).</flag>
<flag name="systemtap">Build support for profiling and tracing using <pkg>dev-util/systemtap</pkg></flag>
<flag name='test'>Install upstream testsuites for end use.</flag>
+ <flag name='yassl'>Enable SSL connections and crypto functions using the bundled yaSSL</flag>
</use>
</pkgmetadata>
diff --git a/dev-db/mysql-cluster/mysql-cluster-7.3.8.ebuild b/dev-db/mysql-cluster/mysql-cluster-7.3.8.ebuild
index 4a10e32edc31..1dcd3582e59d 100644
--- a/dev-db/mysql-cluster/mysql-cluster-7.3.8.ebuild
+++ b/dev-db/mysql-cluster/mysql-cluster-7.3.8.ebuild
@@ -23,6 +23,14 @@ RDEPEND="!media-sound/amarok[embedded]"
# If you want to add a single patch, copy the ebuild to an overlay
# and create your own mysql-extras tarball, looking at 000_index.txt
+src_prepare() {
+ mysql-multilib_src_prepare
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+}
+
# Official test instructions:
# USE='cluster extraengine perl ssl community' \
# FEATURES='test userpriv -usersandbox' \
diff --git a/dev-db/mysql-cluster/mysql-cluster-7.3.9-r1.ebuild b/dev-db/mysql-cluster/mysql-cluster-7.3.9-r1.ebuild
index 20b5fee46b98..c6e01f67ffd6 100644
--- a/dev-db/mysql-cluster/mysql-cluster-7.3.9-r1.ebuild
+++ b/dev-db/mysql-cluster/mysql-cluster-7.3.9-r1.ebuild
@@ -24,6 +24,14 @@ RDEPEND="!media-sound/amarok[embedded]"
# If you want to add a single patch, copy the ebuild to an overlay
# and create your own mysql-extras tarball, looking at 000_index.txt
+src_prepare() {
+ mysql-multilib_src_prepare
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+}
+
# Official test instructions:
# USE='cluster extraengine perl ssl community' \
# FEATURES='test userpriv -usersandbox' \