summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/ois
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/ois')
-rw-r--r--dev-games/ois/Manifest1
-rw-r--r--dev-games/ois/files/ois-1.3-automake-1.13.patch11
-rw-r--r--dev-games/ois/files/ois-1.3-gcc47.patch40
-rw-r--r--dev-games/ois/metadata.xml8
-rw-r--r--dev-games/ois/ois-1.3.ebuild35
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-games/ois/Manifest b/dev-games/ois/Manifest
new file mode 100644
index 000000000000..cfb28dc7cb33
--- /dev/null
+++ b/dev-games/ois/Manifest
@@ -0,0 +1 @@
+DIST ois_v1-3.tar.gz 136739 SHA256 50fa76d827e119a80e2c86a5196ac4354e556f80b0a4fa440f69e1057b37faa1 SHA512 48b7355a9be9c66233691aa5461192fb6e537d284e4366ebf931a76ee3be30f2cf17a4aa350fce6b433eaecf4259414062b9dd5854eaf872b9a18294cfc640c3 WHIRLPOOL 45f0887fd759d0a0a38d6126c1693fabab7724f6835288dd528f1845305ef7eeb4bb78549d0d449e8f2b9714c23b0725e43514565853d3132ff0394981fba197
diff --git a/dev-games/ois/files/ois-1.3-automake-1.13.patch b/dev-games/ois/files/ois-1.3-automake-1.13.patch
new file mode 100644
index 000000000000..fb103e40335a
--- /dev/null
+++ b/dev-games/ois/files/ois-1.3-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- ois-v1-3/configure.ac
++++ ois-v1-3/configure.ac
+@@ -5,7 +5,7 @@
+
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE( [OIS], 1.3.0 )
+-AM_CONFIG_HEADER([includes/config.h])
++AC_CONFIG_HEADERS([includes/config.h])
+
+ dnl Check for programs
+ AC_PROG_CC
diff --git a/dev-games/ois/files/ois-1.3-gcc47.patch b/dev-games/ois/files/ois-1.3-gcc47.patch
new file mode 100644
index 000000000000..d002ec3cffb5
--- /dev/null
+++ b/dev-games/ois/files/ois-1.3-gcc47.patch
@@ -0,0 +1,40 @@
+--- demos/FFConsoleDemo.cpp.old 2012-07-17 08:41:33.667876985 +0200
++++ demos/FFConsoleDemo.cpp 2012-07-17 08:42:01.415928693 +0200
+@@ -7,6 +7,7 @@
+ #include <ios>
+ #include <sstream>
+ #include <vector>
++#include <unistd.h>
+
+ using namespace std;
+
+--- demos/OISConsole.cpp.old 2012-07-17 08:43:44.637681119 +0200
++++ demos/OISConsole.cpp 2012-07-17 08:44:06.653135337 +0200
+@@ -12,6 +12,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <sstream>
++#include <unistd.h>
+
+ ////////////////////////////////////Needed Windows Headers////////////
+ #if defined OIS_WIN32_PLATFORM
+--- src/linux/LinuxJoyStickEvents.cpp.old 2012-07-17 08:37:56.065155660 +0200
++++ src/linux/LinuxJoyStickEvents.cpp 2012-07-17 08:38:33.236545721 +0200
+@@ -33,6 +33,7 @@
+ #include <fcntl.h> //Needed to Open a file descriptor
+ #include <cassert>
+ #include <linux/input.h>
++#include <unistd.h>
+
+
+ #include <sstream>
+--- src/linux/LinuxForceFeedback.cpp.old 2012-07-17 08:40:02.633268854 +0200
++++ src/linux/LinuxForceFeedback.cpp 2012-07-17 08:40:28.642442655 +0200
+@@ -26,6 +26,7 @@
+ #include <cstdlib>
+ #include <errno.h>
+ #include <memory.h>
++#include <unistd.h>
+
+ using namespace OIS;
+
diff --git a/dev-games/ois/metadata.xml b/dev-games/ois/metadata.xml
new file mode 100644
index 000000000000..9a10732db25f
--- /dev/null
+++ b/dev-games/ois/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">wgois</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-games/ois/ois-1.3.ebuild b/dev-games/ois/ois-1.3.ebuild
new file mode 100644
index 000000000000..c2d80ed398bc
--- /dev/null
+++ b/dev-games/ois/ois-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools autotools-utils
+
+MY_P=${PN}-v${PV/./-}
+DESCRIPTION="Object-oriented Input System - A cross-platform C++ input handling library"
+HOMEPAGE="http://sourceforge.net/projects/wgois/"
+SRC_URI="mirror://sourceforge/wgois/${MY_P/-/_}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libX11"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
+
+}