summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-25 06:35:23 +0000
committerSam James <sam@gentoo.org>2021-02-25 06:36:08 +0000
commitdb7aa8c8256f5f1adb39733d6b6b688ecdd148a3 (patch)
treef0186a49f8b844f7589758adb33c79029b23ebbe /dev-games/ois
parentdev-games/ois: add github remote-id (diff)
downloadgentoo-db7aa8c8256f5f1adb39733d6b6b688ecdd148a3.tar.gz
gentoo-db7aa8c8256f5f1adb39733d6b6b688ecdd148a3.tar.bz2
gentoo-db7aa8c8256f5f1adb39733d6b6b688ecdd148a3.zip
dev-games/ois: port 1.3 to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games/ois')
-rw-r--r--dev-games/ois/files/ois-1.3-automake-1.13.patch4
-rw-r--r--dev-games/ois/files/ois-1.3-gcc47.patch16
-rw-r--r--dev-games/ois/ois-1.3-r1.ebuild31
3 files changed, 41 insertions, 10 deletions
diff --git a/dev-games/ois/files/ois-1.3-automake-1.13.patch b/dev-games/ois/files/ois-1.3-automake-1.13.patch
index fb103e40335a..af7aa641e6ae 100644
--- a/dev-games/ois/files/ois-1.3-automake-1.13.patch
+++ b/dev-games/ois/files/ois-1.3-automake-1.13.patch
@@ -1,5 +1,5 @@
---- ois-v1-3/configure.ac
-+++ ois-v1-3/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -5,7 +5,7 @@
AC_CANONICAL_TARGET
diff --git a/dev-games/ois/files/ois-1.3-gcc47.patch b/dev-games/ois/files/ois-1.3-gcc47.patch
index d002ec3cffb5..71c7565e17df 100644
--- a/dev-games/ois/files/ois-1.3-gcc47.patch
+++ b/dev-games/ois/files/ois-1.3-gcc47.patch
@@ -1,5 +1,5 @@
---- demos/FFConsoleDemo.cpp.old 2012-07-17 08:41:33.667876985 +0200
-+++ demos/FFConsoleDemo.cpp 2012-07-17 08:42:01.415928693 +0200
+--- a/demos/FFConsoleDemo.cpp.old 2012-07-17 08:41:33.667876985 +0200
++++ b/demos/FFConsoleDemo.cpp 2012-07-17 08:42:01.415928693 +0200
@@ -7,6 +7,7 @@
#include <ios>
#include <sstream>
@@ -8,8 +8,8 @@
using namespace std;
---- demos/OISConsole.cpp.old 2012-07-17 08:43:44.637681119 +0200
-+++ demos/OISConsole.cpp 2012-07-17 08:44:06.653135337 +0200
+--- a/demos/OISConsole.cpp.old 2012-07-17 08:43:44.637681119 +0200
++++ b/demos/OISConsole.cpp 2012-07-17 08:44:06.653135337 +0200
@@ -12,6 +12,7 @@
#include <iostream>
#include <vector>
@@ -18,8 +18,8 @@
////////////////////////////////////Needed Windows Headers////////////
#if defined OIS_WIN32_PLATFORM
---- src/linux/LinuxJoyStickEvents.cpp.old 2012-07-17 08:37:56.065155660 +0200
-+++ src/linux/LinuxJoyStickEvents.cpp 2012-07-17 08:38:33.236545721 +0200
+--- a/src/linux/LinuxJoyStickEvents.cpp.old 2012-07-17 08:37:56.065155660 +0200
++++ b/src/linux/LinuxJoyStickEvents.cpp 2012-07-17 08:38:33.236545721 +0200
@@ -33,6 +33,7 @@
#include <fcntl.h> //Needed to Open a file descriptor
#include <cassert>
@@ -28,8 +28,8 @@
#include <sstream>
---- src/linux/LinuxForceFeedback.cpp.old 2012-07-17 08:40:02.633268854 +0200
-+++ src/linux/LinuxForceFeedback.cpp 2012-07-17 08:40:28.642442655 +0200
+--- a/src/linux/LinuxForceFeedback.cpp.old 2012-07-17 08:40:02.633268854 +0200
++++ b/src/linux/LinuxForceFeedback.cpp 2012-07-17 08:40:28.642442655 +0200
@@ -26,6 +26,7 @@
#include <cstdlib>
#include <errno.h>
diff --git a/dev-games/ois/ois-1.3-r1.ebuild b/dev-games/ois/ois-1.3-r1.ebuild
new file mode 100644
index 000000000000..5b5f0127621b
--- /dev/null
+++ b/dev-games/ois/ois-1.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=${PN}-v${PV/./-}
+DESCRIPTION="Object-oriented Input System - A cross-platform C++ input handling library"
+HOMEPAGE="https://sourceforge.net/projects/wgois/"
+SRC_URI="mirror://sourceforge/wgois/${MY_P/-/_}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libX11"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}