summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 15:38:22 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:16 +0100
commit914cd68f2a4ea1c12f9898c79776af934a4d22f9 (patch)
treee615c6bef5ed171c24027c0c25762f2486a872a8 /dev-haskell/fail
parentdev-haskell/stack: bump up to 2.3.1 (diff)
downloadgentoo-914cd68f2a4ea1c12f9898c79776af934a4d22f9.tar.gz
gentoo-914cd68f2a4ea1c12f9898c79776af934a4d22f9.tar.bz2
gentoo-914cd68f2a4ea1c12f9898c79776af934a4d22f9.zip
dev-haskell/fail: remove cabal dep to break circular depends
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/fail')
-rw-r--r--dev-haskell/fail/fail-4.9.0.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-haskell/fail/fail-4.9.0.0.ebuild b/dev-haskell/fail/fail-4.9.0.0.ebuild
index 01c2904253c0..f5bb54330f1d 100644
--- a/dev-haskell/fail/fail-4.9.0.0.ebuild
+++ b/dev-haskell/fail/fail-4.9.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,6 +6,9 @@ EAPI=5
# ebuild generated by hackport 0.4.7.9999
CABAL_FEATURES="lib profile" # ghc-8 already provides module; haddock hoogle hscolour"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
inherit haskell-cabal
DESCRIPTION="Forward-compatible MonadFail class"
@@ -19,6 +22,4 @@ IUSE=""
RDEPEND=">=dev-lang/ghc-7.4.1:=
"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
-"
+DEPEND="${RDEPEND}"