summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-06 12:45:07 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-06 12:45:07 +0100
commit365ea8fd22f3d89367adb93071e7f5077aad356b (patch)
tree884c2891e8131cb4118d3b00361bcbd589cd1b7e /dev-haskell/gtk3
parentdev-haskell/gtk3: add a workaround against glib-2.62 (diff)
downloadgentoo-365ea8fd22f3d89367adb93071e7f5077aad356b.tar.gz
gentoo-365ea8fd22f3d89367adb93071e7f5077aad356b.tar.bz2
gentoo-365ea8fd22f3d89367adb93071e7f5077aad356b.zip
dev-haskell/gtk3: drop old
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/gtk3')
-rw-r--r--dev-haskell/gtk3/Manifest2
-rw-r--r--dev-haskell/gtk3/gtk3-0.13.7.ebuild52
-rw-r--r--dev-haskell/gtk3/gtk3-0.14.6.ebuild40
-rw-r--r--dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild48
4 files changed, 0 insertions, 142 deletions
diff --git a/dev-haskell/gtk3/Manifest b/dev-haskell/gtk3/Manifest
index 55cb495552e5..7ec57aea8f96 100644
--- a/dev-haskell/gtk3/Manifest
+++ b/dev-haskell/gtk3/Manifest
@@ -1,3 +1 @@
-DIST gtk3-0.13.7.tar.gz 673031 BLAKE2B 4a99b1c430cad1d940b9c30cbf4ab2bcddf64d2bdcc645b2ad37c86069a4817c677ccc3552007c9aeb41755125650cea19c70786dd4a64d348bf483bd08a3073 SHA512 c350ae55a7044684e6f2d94592decfcd01d3e96900a468cd417bad52713502c89c328f96cd4ff29647169a76287b8dada9654d46c4dc884c0dab0590ad57762e
-DIST gtk3-0.14.6.tar.gz 675439 BLAKE2B 7b5699db78f68e763ba972c2a82aa4044d2b97e60137443732b199afb2b611758130b9dcc8240da7492d0853c8bbdc88aa9e18884798eb1c33d7f6af7fbd9409 SHA512 d03930164fa117ebd6bcc79b79a9cfc0449c5ed0b3de6999f26ad63673a67a146f989245efa68b4e1484091689b350a5df95ed49bbbe9d4a30fbe418cbb37209
DIST gtk3-0.14.9.tar.gz 676542 BLAKE2B d2aeec5fd59dfe71e6c62e6abf60370f12ca8d7a3d3716593151a2f7697e8b53bbf4e8c094df1a2162703422cfb390407c8a83b564fed78c16f94d3d07036122 SHA512 aaf2a257c74f5b0a569d0e61aef535e2f0c8158feb34bed523c7aff31cf155098f93d3a88ba49bea906ae669bf63fb0486f4c747a620c2199c2e7859486e7270
diff --git a/dev-haskell/gtk3/gtk3-0.13.7.ebuild b/dev-haskell/gtk3/gtk3-0.13.7.ebuild
deleted file mode 100644
index f515449a1c5f..000000000000
--- a/dev-haskell/gtk3/gtk3-0.13.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-#nocabaldep is for the fancy cabal-detection feature at build-time
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour nocabaldep"
-inherit haskell-cabal
-
-DESCRIPTION="Binding to the Gtk+ graphical user interface library"
-HOMEPAGE="http://projects.haskell.org/gtk2hs/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="examples +fmode-binary +gio"
-
-RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
- >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
- >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
- dev-haskell/transformers:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- dev-libs/glib:2
- x11-libs/gtk+:3
- gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
- virtual/pkgconfig
-"
-
-src_prepare() {
- # workaround for module order
- cabal_chdeps \
- 'other-modules:' 'exposed-modules:'
- # fix build with gcc 5.1.0 and later https://github.com/gtk2hs/gtk2hs/issues/104
- sed -e 's@gccProg, "--cppopts=-E"@gccProg, "--cppopts=-E", "--cppopts=-P"@' \
- -i Gtk2HsSetup.hs || die
-}
-
-src_configure() {
- cabal_src_configure \
- $(cabal_flag examples build-demos) \
- $(cabal_flag fmode-binary fmode-binary) \
- $(cabal_flag gio have-gio) \
- --flags=-have-quartz-gtk
-}
diff --git a/dev-haskell/gtk3/gtk3-0.14.6.ebuild b/dev-haskell/gtk3/gtk3-0.14.6.ebuild
deleted file mode 100644
index 4a1e749390e9..000000000000
--- a/dev-haskell/gtk3/gtk3-0.14.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.9999
-#hackport: flags: have-gio:gio,build-demos:examples
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Binding to the Gtk+ 3 graphical user interface library"
-HOMEPAGE="http://projects.haskell.org/gtk2hs/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+fmode-binary +gio"
-
-RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
- >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
- >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- dev-libs/glib:2
- x11-libs/gtk+:3
- gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24
- virtual/pkgconfig
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag fmode-binary fmode-binary) \
- $(cabal_flag gio have-gio)
-}
diff --git a/dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild b/dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild
deleted file mode 100644
index 700014ceb8be..000000000000
--- a/dev-haskell/gtk3/gtk3-0.14.9-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.5.5.9999
-#hackport: flags: have-gio:gio,build-demos:examples
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Binding to the Gtk+ 3 graphical user interface library"
-HOMEPAGE="http://projects.haskell.org/gtk2hs/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+fmode-binary +gio"
-
-RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
- >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
- >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- dev-libs/glib:2
- x11-libs/gtk+:3
- gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.1
- >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'Cabal >= 1.24 && < 2.3' 'Cabal >= 1.24 && < 3.1'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag fmode-binary fmode-binary) \
- $(cabal_flag gio have-gio)
-}