summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 12:04:48 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:35 +0100
commit6d04758e1c67cc04d5933dafa5c2135642ad098c (patch)
tree1b48810de0082e12c296bd6d69b599d82ae74433 /dev-haskell/lukko
parentdev-haskell/temporary: bump up to 1.3 (diff)
downloadgentoo-6d04758e1c67cc04d5933dafa5c2135642ad098c.tar.gz
gentoo-6d04758e1c67cc04d5933dafa5c2135642ad098c.tar.bz2
gentoo-6d04758e1c67cc04d5933dafa5c2135642ad098c.zip
dev-haskell/lukko: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/lukko')
-rw-r--r--dev-haskell/lukko/Manifest1
-rw-r--r--dev-haskell/lukko/lukko-0.1.1.2.ebuild36
-rw-r--r--dev-haskell/lukko/metadata.xml47
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/lukko/Manifest b/dev-haskell/lukko/Manifest
new file mode 100644
index 000000000000..4bd93cb9427f
--- /dev/null
+++ b/dev-haskell/lukko/Manifest
@@ -0,0 +1 @@
+DIST lukko-0.1.1.2.tar.gz 28366 BLAKE2B 8e7a0257c187ed76f2399a2ca381210ad44d683faff74ca583658eab13545e6809fe6ea57b4c4c22c16560272c0d53736183437e4f5ad64919d98dbac239a864 SHA512 fe3a6687b741491ebaeace29c8d4d01307fad43f0e649c087fef24ec227eb231541fa1500e1685c814eb2a1ea472546033e837ce84fa64df79f00b19f8abebb6
diff --git a/dev-haskell/lukko/lukko-0.1.1.2.ebuild b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
new file mode 100644
index 000000000000..dc9393ce2aea
--- /dev/null
+++ b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File locking"
+HOMEPAGE="http://hackage.haskell.org/package/lukko"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ofd-locking"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+ test? ( >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
+ >=dev-haskell/singleton-bool-0.1.5 <dev-haskell/singleton-bool-0.2
+ >=dev-haskell/tagged-0.8.5 <dev-haskell/tagged-0.9
+ >=dev-haskell/tasty-1.2.3 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-expected-failure-0.11.1.2 <dev-haskell/tasty-expected-failure-0.12
+ >=dev-haskell/tasty-hunit-0.10.0.2 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/temporary-1.3 <dev-haskell/temporary-1.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag ofd-locking ofd-locking)
+}
diff --git a/dev-haskell/lukko/metadata.xml b/dev-haskell/lukko/metadata.xml
new file mode 100644
index 000000000000..a2f47beee925
--- /dev/null
+++ b/dev-haskell/lukko/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="ofd-locking">Enable open file descriptor locking. Available on Linux (kernel 3.15, released Jun 8, 2014).</flag>
+ </use>
+ <longdescription>
+ This package provides access to platform dependent file locking APIs:
+
+ * Open file descriptor locking on Linux (&quot;Lukko.OFD&quot;)
+ * @flock@ locking on unix platforms (&quot;Lukko.FLock&quot;)
+ * Windows locking @LockFileEx@ (&quot;Lukko.Windows&quot;)
+ * No-op locking, which throws exceptions (&quot;Lukko.NoOp&quot;)
+ * &quot;Lukko&quot; module exports the best option for the target platform with uniform API.
+
+ There are alternative file locking packages:
+
+ * &quot;GHC.IO.Handle.Lock&quot; in @base &gt;= 4.10@ is good enough for most use cases.
+ However, uses only &#39;Handle&#39;s so these locks cannot be used for intra-process locking.
+ (You should use e.g. &#39;MVar&#39; in addition).
+
+ * &lt;https://hackage.haskell.org/package/filelock filelock&gt; doesn&#39;t support OFD locking.
+
+ /Lukko/ means lock in Finnish.
+
+ Submodules &quot;Lukko.OFD&quot;, &quot;Lukko.Windows&quot; etc are available based on following conditions.
+
+ @
+ if os(windows)
+ \ cpp-options: -DHAS_WINDOWS_LOCK
+
+ elif (os(linux) &amp;&amp; flag(ofd-locking))
+ \ cpp-options: -DHAS_OFD_LOCKING
+ \ cpp-options: -DHAS_FLOCK
+
+ elif !(os(solaris) || os(aix))
+ \ cpp-options: -DHAS_FLOCK
+ @
+
+ &quot;Lukko.FLock&quot; is available on not (Windows or Solaris or AIX).
+ &quot;Lukko.NoOp&quot; is always available.
+ </longdescription>
+</pkgmetadata>