summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-29 19:25:42 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-29 19:36:59 +0100
commitbedf56d37838e88fcefce334ecef8a045956ac1e (patch)
tree2ce1ec0e9b5bd99c0c116ac76f7092836dc165e9 /dev-haskell/mysql
parentdev-cpp/yaml-cpp: Stabilize 0.6.3-r3 ppc, #719150 (diff)
downloadgentoo-bedf56d37838e88fcefce334ecef8a045956ac1e.tar.gz
gentoo-bedf56d37838e88fcefce334ecef8a045956ac1e.tar.bz2
gentoo-bedf56d37838e88fcefce334ecef8a045956ac1e.zip
dev-haskell/mysql: new package, a depend of esqueleto-3.3
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/mysql')
-rw-r--r--dev-haskell/mysql/Manifest1
-rw-r--r--dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch29
-rw-r--r--dev-haskell/mysql/metadata.xml20
-rw-r--r--dev-haskell/mysql/mysql-0.1.7.ebuild34
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/mysql/Manifest b/dev-haskell/mysql/Manifest
new file mode 100644
index 000000000000..ab6ba5ef4a0b
--- /dev/null
+++ b/dev-haskell/mysql/Manifest
@@ -0,0 +1 @@
+DIST mysql-0.1.7.tar.gz 16544 BLAKE2B a7617293f2dc970b9ace46c0b2a9452f23a90524181a1b37aa10176f2ba4ee3f9e967d94faa9e714a947e50b59d368c79fc59602cbc8e0792e4e396a09b4596c SHA512 45074050e17fed48f865c21ccca72cdcca02631715ee4a34b46f71fda74b50ab6332d8998d1047e6ae43df84e3fc865610153f15c3092c6b300e3e5ada30efa1
diff --git a/dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch b/dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch
new file mode 100644
index 000000000000..475d3f79722c
--- /dev/null
+++ b/dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch
@@ -0,0 +1,29 @@
+diff --git a/Setup.lhs b/Setup.lhs
+index 2bf8d37..8fb2d3f 100644
+--- a/Setup.lhs
++++ b/Setup.lhs
+@@ -14,15 +14,2 @@ import Distribution.Verbosity
+
+--- A Cabal 1.16 vs 1.18 compatibility hack, as in 1.18
+--- findProgramLocation has a new (unused in this case) parameter.
+--- ConstOrId adds this parameter when types say it is mandatory.
+-class ConstOrId a b where
+- constOrId :: a -> b
+-
+-instance ConstOrId a a where
+- constOrId = id
+-
+-instance ConstOrId a (b -> a) where
+- constOrId = const
+-
+-
+ main = defaultMainWithHooks simpleUserHooks {
+@@ -39,5 +26,5 @@ main = defaultMainWithHooks simpleUserHooks {
+ mysqlConfigProgram = (simpleProgram "mysql_config") {
+- programFindLocation = \verbosity -> constOrId $ liftM2 mplus
+- (findProgramLocation verbosity "mysql_config")
+- (findProgramLocation verbosity "mysql_config5")
++ programFindLocation = \verbosity path -> liftM2 mplus
++ (findProgramOnSearchPath verbosity path "mysql_config")
++ (findProgramOnSearchPath verbosity path "mysql_config5")
+ }
diff --git a/dev-haskell/mysql/metadata.xml b/dev-haskell/mysql/metadata.xml
new file mode 100644
index 000000000000..a966cd047c61
--- /dev/null
+++ b/dev-haskell/mysql/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A low-level client library for the MySQL database, implemented as
+ bindings to the C @mysqlclient@ API.
+
+ /Important licensing note/: This library is BSD-licensed under the
+ terms of the MySQL FOSS License Exception
+ &lt;http://www.mysql.com/about/legal/licensing/foss-exception/&gt;.
+
+ Since this library links against the GPL-licensed @mysqlclient@
+ library, a non-open-source application that uses it /may/ be
+ subject to the terms of the GPL.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mysql/mysql-0.1.7.ebuild b/dev-haskell/mysql/mysql-0.1.7.ebuild
new file mode 100644
index 000000000000..430ba9a0ad8a
--- /dev/null
+++ b/dev-haskell/mysql/mysql-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A low-level MySQL client library"
+HOMEPAGE="https://github.com/paul-rouse/mysql"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs local mysql
+
+RDEPEND=">=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}