summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-08-01 15:38:09 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:04:42 +0100
commit4c07de34dcdecc569ca058108c408b0fe3bc7140 (patch)
treea7e5fcf6294609601bd18421912bd5493e46555b /dev-haskell
parentdev-haskell/httpd-shed: bump up to 0.4.1.1 (diff)
downloadgentoo-4c07de34dcdecc569ca058108c408b0fe3bc7140.tar.gz
gentoo-4c07de34dcdecc569ca058108c408b0fe3bc7140.tar.bz2
gentoo-4c07de34dcdecc569ca058108c408b0fe3bc7140.zip
dev-haskell/patience: patch for >=dev-lang/ghc-8.6
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch20
-rw-r--r--dev-haskell/patience/patience-0.1.1-r1.ebuild26
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch b/dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch
new file mode 100644
index 000000000000..e844e1d9df5e
--- /dev/null
+++ b/dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch
@@ -0,0 +1,20 @@
+diff -ru patience-0.1.1/Data/Algorithm/Patience.hs patience-modified/Data/Algorithm/Patience.hs
+--- patience-0.1.1/Data/Algorithm/Patience.hs 2011-08-17 08:08:14.000000000 +0800
++++ patience-modified/Data/Algorithm/Patience.hs 2018-07-11 15:17:45.021338649 +0800
+@@ -15,6 +15,7 @@
+ import Data.Sequence ( (<|), (|>), (><), ViewL(..), ViewR(..) )
+ import qualified Data.Foldable as F
+ import qualified Data.Map as M
++import qualified Data.Map.Strict as MS
+ import qualified Data.IntMap as IM
+
+ import Data.List
+@@ -68,7 +69,7 @@
+ -- Elements whose second component appears exactly once.
+ unique :: (Ord t) => S.Seq (a,t) -> M.Map t a
+ unique = M.mapMaybe id . F.foldr ins M.empty where
+- ins (a,x) = M.insertWith' (\_ _ -> Nothing) x (Just a)
++ ins (a,x) = MS.insertWith (\_ _ -> Nothing) x (Just a)
+
+ -- Given two sequences of numbered "lines", returns a list of points
+ -- where unique lines match up.
diff --git a/dev-haskell/patience/patience-0.1.1-r1.ebuild b/dev-haskell/patience/patience-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..54fcdd486411
--- /dev/null
+++ b/dev-haskell/patience/patience-0.1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Patience diff and longest increasing subsequence"
+HOMEPAGE="http://hackage.haskell.org/package/patience"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.6.patch)