summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/struts-core/struts-core-2.3.15.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/struts-core/struts-core-2.3.15.2.ebuild')
-rw-r--r--dev-java/struts-core/struts-core-2.3.15.2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/struts-core/struts-core-2.3.15.2.ebuild b/dev-java/struts-core/struts-core-2.3.15.2.ebuild
new file mode 100644
index 000000000000..9b3f261db9a8
--- /dev/null
+++ b/dev-java/struts-core/struts-core-2.3.15.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="struts"
+MY_P="${MY_PN}-${PV}-src"
+
+DESCRIPTION="A powerful Model View Controller Framework for JSP/Servlets: Core"
+SRC_URI="mirror://apache/struts/source/${MY_P}.zip
+ http://dev.gentoo.org/~tomwij/files/dist/${MY_PN}-build.xml-${PV}.tar.xz"
+HOMEPAGE="http://struts.apache.org/index.html"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+
+COMMON_DEPS="dev-java/commons-fileupload:0
+ dev-java/commons-lang:3.1
+ dev-java/freemarker:2.3
+ dev-java/ognl:3.0
+ dev-java/struts-xwork:2
+ dev-java/velocity:0
+ java-virtuals/servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPS}"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src/core"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="struts-xwork-2"
+
+src_unpack() {
+ unpack ${MY_P}.zip
+ cd "${WORKDIR}"/${MY_PN}-${PV}/src || die
+ unpack ${MY_PN}-build.xml-${PV}.tar.xz
+
+ java-pkg_getjars commons-fileupload,commons-lang-3.1,freemarker-2.3,ognl-3.0,velocity,servlet-api-3.0
+}
+
+java_prepare() {
+ find . -name '*.jar' -print -delete || die
+
+ epatch "${FILESDIR}"/${MY_PN}-${PV}-build.xml-classpath.patch
+ epatch "${FILESDIR}"/${MY_PN}-${PV}-build.xml-manifest.patch
+}
+
+src_test() {
+ EANT_TEST_EXTRA_ARGS="-Djunit.present=true" java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_PN}2-core-${PV}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/com
+}