summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 15:44:34 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-12 17:03:16 +0100
commitbc46e49ff67cf1e5157ab95b41e780067f433685 (patch)
tree05bd3754d0503120787207d3238f8bd71637959b /dev-lang/python/python-2.7.10-r3.ebuild
parentdev-lang/python: Remove redundant ebuilds (diff)
downloadgentoo-bc46e49ff67cf1e5157ab95b41e780067f433685.tar.gz
gentoo-bc46e49ff67cf1e5157ab95b41e780067f433685.tar.bz2
gentoo-bc46e49ff67cf1e5157ab95b41e780067f433685.zip
dev-lang/python: Fix epython.py module first install
Fix the issues in obtaining sitedir for epython.py module install when dev-lang/python is not yet installed.
Diffstat (limited to 'dev-lang/python/python-2.7.10-r3.ebuild')
-rw-r--r--dev-lang/python/python-2.7.10-r3.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.7.10-r3.ebuild b/dev-lang/python/python-2.7.10-r3.ebuild
index 31c6506f0e69..b6aeaf79875c 100644
--- a/dev-lang/python/python-2.7.10-r3.ebuild
+++ b/dev-lang/python/python-2.7.10-r3.ebuild
@@ -304,16 +304,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}