summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 15:44:34 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-12 17:03:16 +0100
commitbc46e49ff67cf1e5157ab95b41e780067f433685 (patch)
tree05bd3754d0503120787207d3238f8bd71637959b /dev-lang/python
parentdev-lang/python: Remove redundant ebuilds (diff)
downloadgentoo-bc46e49ff67cf1e5157ab95b41e780067f433685.tar.gz
gentoo-bc46e49ff67cf1e5157ab95b41e780067f433685.tar.bz2
gentoo-bc46e49ff67cf1e5157ab95b41e780067f433685.zip
dev-lang/python: Fix epython.py module first install
Fix the issues in obtaining sitedir for epython.py module install when dev-lang/python is not yet installed.
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.10-r2.ebuild10
-rw-r--r--dev-lang/python/python-2.7.10-r3.ebuild10
-rw-r--r--dev-lang/python/python-2.7.10.ebuild10
-rw-r--r--dev-lang/python/python-2.7.9-r1.ebuild10
-rw-r--r--dev-lang/python/python-3.3.5-r1.ebuild10
-rw-r--r--dev-lang/python/python-3.3.5-r2.ebuild10
-rw-r--r--dev-lang/python/python-3.3.5-r3.ebuild10
-rw-r--r--dev-lang/python/python-3.4.1.ebuild9
-rw-r--r--dev-lang/python/python-3.4.3-r2.ebuild10
-rw-r--r--dev-lang/python/python-3.4.3-r3.ebuild10
-rw-r--r--dev-lang/python/python-3.4.3.ebuild10
-rw-r--r--dev-lang/python/python-3.5.0-r1.ebuild10
-rw-r--r--dev-lang/python/python-3.5.0-r2.ebuild10
13 files changed, 78 insertions, 51 deletions
diff --git a/dev-lang/python/python-2.7.10-r2.ebuild b/dev-lang/python/python-2.7.10-r2.ebuild
index a8eeb9f16d81..2bb8c27092ad 100644
--- a/dev-lang/python/python-2.7.10-r2.ebuild
+++ b/dev-lang/python/python-2.7.10-r2.ebuild
@@ -306,16 +306,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-2.7.10-r3.ebuild b/dev-lang/python/python-2.7.10-r3.ebuild
index 31c6506f0e69..b6aeaf79875c 100644
--- a/dev-lang/python/python-2.7.10-r3.ebuild
+++ b/dev-lang/python/python-2.7.10-r3.ebuild
@@ -304,16 +304,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-2.7.10.ebuild b/dev-lang/python/python-2.7.10.ebuild
index 2d6f00d0b1bc..8f7a67687073 100644
--- a/dev-lang/python/python-2.7.10.ebuild
+++ b/dev-lang/python/python-2.7.10.ebuild
@@ -314,16 +314,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-2.7.9-r1.ebuild b/dev-lang/python/python-2.7.9-r1.ebuild
index 20cdedb0ea7f..1e9eb6ae3249 100644
--- a/dev-lang/python/python-2.7.9-r1.ebuild
+++ b/dev-lang/python/python-2.7.9-r1.ebuild
@@ -315,16 +315,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.3.5-r1.ebuild b/dev-lang/python/python-3.3.5-r1.ebuild
index 64e520ba1e96..c790c996d675 100644
--- a/dev-lang/python/python-3.3.5-r1.ebuild
+++ b/dev-lang/python/python-3.3.5-r1.ebuild
@@ -280,16 +280,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.3.5-r2.ebuild b/dev-lang/python/python-3.3.5-r2.ebuild
index b6256f8e709b..f35f7efc7e10 100644
--- a/dev-lang/python/python-3.3.5-r2.ebuild
+++ b/dev-lang/python/python-3.3.5-r2.ebuild
@@ -286,16 +286,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.3.5-r3.ebuild b/dev-lang/python/python-3.3.5-r3.ebuild
index 4b773d22ffff..3049ce1f71bc 100644
--- a/dev-lang/python/python-3.3.5-r3.ebuild
+++ b/dev-lang/python/python-3.3.5-r3.ebuild
@@ -291,16 +291,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${PYVER}" "${ED}etc/init.d/pydoc-${PYVER}" || die "sed failed"
# for python-exec
- python_export python${PYVER} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.4.1.ebuild b/dev-lang/python/python-3.4.1.ebuild
index 5c5df4c798b4..2f271ee72a0e 100644
--- a/dev-lang/python/python-3.4.1.ebuild
+++ b/dev-lang/python/python-3.4.1.ebuild
@@ -276,15 +276,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.4.3-r2.ebuild b/dev-lang/python/python-3.4.3-r2.ebuild
index 86ebb5e5c6b2..aea8b53602d9 100644
--- a/dev-lang/python/python-3.4.3-r2.ebuild
+++ b/dev-lang/python/python-3.4.3-r2.ebuild
@@ -267,16 +267,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.4.3-r3.ebuild b/dev-lang/python/python-3.4.3-r3.ebuild
index dba49e89bb85..aaaa72aca152 100644
--- a/dev-lang/python/python-3.4.3-r3.ebuild
+++ b/dev-lang/python/python-3.4.3-r3.ebuild
@@ -274,16 +274,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${PYVER}" "${ED}etc/init.d/pydoc-${PYVER}" || die "sed failed"
# for python-exec
- python_export python${PYVER} EPYTHON PYTHON PYTHON_SITEDIR
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.4.3.ebuild b/dev-lang/python/python-3.4.3.ebuild
index 3ab43cf075af..2f95394cf7a9 100644
--- a/dev-lang/python/python-3.4.3.ebuild
+++ b/dev-lang/python/python-3.4.3.ebuild
@@ -275,16 +275,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.5.0-r1.ebuild b/dev-lang/python/python-3.5.0-r1.ebuild
index d808c8357f5a..e67b55e388e6 100644
--- a/dev-lang/python/python-3.5.0-r1.ebuild
+++ b/dev-lang/python/python-3.5.0-r1.ebuild
@@ -273,16 +273,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}
diff --git a/dev-lang/python/python-3.5.0-r2.ebuild b/dev-lang/python/python-3.5.0-r2.ebuild
index e3293e3792e4..caa9e3531aeb 100644
--- a/dev-lang/python/python-3.5.0-r2.ebuild
+++ b/dev-lang/python/python-3.5.0-r2.ebuild
@@ -277,16 +277,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${PYVER}" "${ED}etc/init.d/pydoc-${PYVER}" || die "sed failed"
# for python-exec
- python_export python${PYVER} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}