summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-09 02:33:48 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-09 02:34:01 -0700
commit02aec2211dbed3353527e8ddb7969b00240eea68 (patch)
tree32a15d664feae80848dd268213743b0ea2176ed3 /dev-lang
parentnet-libs/nodejs: Drop obsolete patch from live ebuild (diff)
downloadgentoo-02aec2211dbed3353527e8ddb7969b00240eea68.tar.gz
gentoo-02aec2211dbed3353527e8ddb7969b00240eea68.tar.bz2
gentoo-02aec2211dbed3353527e8ddb7969b00240eea68.zip
dev-lang/rust: update boostrap_rust_version_check()
we don't need it for binpkgs Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.45.2.ebuild1
-rw-r--r--dev-lang/rust/rust-1.46.0.ebuild1
-rw-r--r--dev-lang/rust/rust-1.47.0.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.45.2.ebuild b/dev-lang/rust/rust-1.45.2.ebuild
index dbb1d9183f1f..5c87a5c5a60e 100644
--- a/dev-lang/rust/rust-1.45.2.ebuild
+++ b/dev-lang/rust/rust-1.45.2.ebuild
@@ -131,6 +131,7 @@ toml_usex() {
boostrap_rust_version_check() {
# never call from pkg_pretend. eselect-rust may be not installed yet.
+ [[ ${MERGE_TYPE} == binary ]] && return
local rustc_wanted="$(ver_cut 1).$(($(ver_cut 2) - 1))"
local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
rustc_version=${rustc_version[0]#rust-bin-}
diff --git a/dev-lang/rust/rust-1.46.0.ebuild b/dev-lang/rust/rust-1.46.0.ebuild
index 1eeee9eb5160..ceaa6d45c121 100644
--- a/dev-lang/rust/rust-1.46.0.ebuild
+++ b/dev-lang/rust/rust-1.46.0.ebuild
@@ -130,6 +130,7 @@ toml_usex() {
boostrap_rust_version_check() {
# never call from pkg_pretend. eselect-rust may be not installed yet.
+ [[ ${MERGE_TYPE} == binary ]] && return
local rustc_wanted="$(ver_cut 1).$(($(ver_cut 2) - 1))"
local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
rustc_version=${rustc_version[0]#rust-bin-}
diff --git a/dev-lang/rust/rust-1.47.0.ebuild b/dev-lang/rust/rust-1.47.0.ebuild
index bc0dd9a95b40..a5041ff03fed 100644
--- a/dev-lang/rust/rust-1.47.0.ebuild
+++ b/dev-lang/rust/rust-1.47.0.ebuild
@@ -133,6 +133,7 @@ toml_usex() {
boostrap_rust_version_check() {
# never call from pkg_pretend. eselect-rust may be not installed yet.
+ [[ ${MERGE_TYPE} == binary ]] && return
local rustc_wanted="$(ver_cut 1).$(($(ver_cut 2) - 1))"
local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
rustc_version=${rustc_version[0]#rust-bin-}