summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-10-30 20:56:26 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-10-30 22:21:41 -0400
commita8ec177bc04cd7de2814c680b089177a4a15dc84 (patch)
tree0d4e23e97335e61fff85248de94268ce2ddf21d7 /dev-lang
parentdev-lang/php: remove redundant "if use odbc" check. (diff)
downloadgentoo-a8ec177bc04cd7de2814c680b089177a4a15dc84.tar.gz
gentoo-a8ec177bc04cd7de2814c680b089177a4a15dc84.tar.bz2
gentoo-a8ec177bc04cd7de2814c680b089177a4a15dc84.zip
dev-lang/php: remove redundant "if use iodbc" check.
The use_with function doesn't do anything if its USE flag is disabled, so there's no reason to wrap use_with in "if use...". This use_with block was also merged with the one for USE=odbc. Gentoo-Bug: 551526 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/php-5.6.15.ebuild8
-rw-r--r--dev-lang/php/php-7.0.0_rc5.ebuild8
2 files changed, 4 insertions, 12 deletions
diff --git a/dev-lang/php/php-5.6.15.ebuild b/dev-lang/php/php-5.6.15.ebuild
index b886802fc3d3..dd6915cc5b3b 100644
--- a/dev-lang/php/php-5.6.15.ebuild
+++ b/dev-lang/php/php-5.6.15.ebuild
@@ -464,12 +464,8 @@ src_configure() {
# ODBC support
my_conf+="
- $(use_with odbc unixODBC ${EPREFIX}/usr)"
-
- if use iodbc ; then
- my_conf+="
- $(use_with iodbc iodbc ${EPREFIX}/usr)"
- fi
+ $(use_with odbc unixODBC ${EPREFIX}/usr)
+ $(use_with iodbc iodbc ${EPREFIX}/usr)"
# Oracle support
if use oci8-instant-client ; then
diff --git a/dev-lang/php/php-7.0.0_rc5.ebuild b/dev-lang/php/php-7.0.0_rc5.ebuild
index 481989304c68..f0e475acbe94 100644
--- a/dev-lang/php/php-7.0.0_rc5.ebuild
+++ b/dev-lang/php/php-7.0.0_rc5.ebuild
@@ -441,12 +441,8 @@ src_configure() {
# ODBC support
my_conf+="
- $(use_with odbc unixODBC ${EPREFIX}/usr)"
-
- if use iodbc ; then
- my_conf+="
- $(use_with iodbc iodbc ${EPREFIX}/usr)"
- fi
+ $(use_with odbc unixODBC ${EPREFIX}/usr)
+ $(use_with iodbc iodbc ${EPREFIX}/usr)"
# Oracle support
if use oci8-instant-client ; then