summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-06 23:19:14 -0800
committerMart Raudsepp <leio@gentoo.org>2019-02-18 20:57:34 +0200
commit697d1b58cdea610ab8cfc6c88cff37462946c5f2 (patch)
tree5c3e46eebf9b131bce74a08e63e243960abc040f /dev-libs/atk/atk-2.30.0.ebuild
parentmedia-libs/mesa: Version bump to 18.3.4 (diff)
downloadgentoo-697d1b58cdea610ab8cfc6c88cff37462946c5f2.tar.gz
gentoo-697d1b58cdea610ab8cfc6c88cff37462946c5f2.tar.bz2
gentoo-697d1b58cdea610ab8cfc6c88cff37462946c5f2.zip
dev-libs/atk: Version bump to 2.30.0
Signed-off-by: Matt Turner <mattst88@gentoo.org> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/atk/atk-2.30.0.ebuild')
-rw-r--r--dev-libs/atk/atk-2.30.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/atk/atk-2.30.0.ebuild b/dev-libs/atk/atk-2.30.0.ebuild
new file mode 100644
index 000000000000..496cdb291e58
--- /dev/null
+++ b/dev-libs/atk/atk-2.30.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org meson multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="gtk-doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.25 )
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ >=sys-devel/gettext-0.19.8
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-use-basename-instead-of-filename.patch
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocs=$(multilib_native_usex gtk-doc true false)
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}