summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-09-30 22:35:46 +0200
committerMichał Górny <mgorny@gentoo.org>2015-09-30 22:40:22 +0200
commit8d3e54d82cf53ab67e01f3d980efc73d23d69589 (patch)
treedaff13e1a05cd01489681c07fa273ab7e3e8d551 /dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild
parentwww-client/links: Version bump. (diff)
downloadgentoo-8d3e54d82cf53ab67e01f3d980efc73d23d69589.tar.gz
gentoo-8d3e54d82cf53ab67e01f3d980efc73d23d69589.tar.bz2
gentoo-8d3e54d82cf53ab67e01f3d980efc73d23d69589.zip
dev-libs/jsoncpp: Bump to 1.6.5
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild b/dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild
new file mode 100644
index 000000000000..3dbd839f047d
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSONCPP_WITH_TESTS=$(usex test)
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+
+ -DBUILD_SHARED_LIBS=ON
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ -DINCLUDE_INSTALL_DIR="${EPREFIX}"/usr/include/jsoncpp
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ "${EPYTHON}" doxybuild.py --doxygen=/usr/bin/doxygen || die
+ fi
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" jsoncpp_check
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ dohtml dist/doxygen/jsoncpp*/*
+ fi
+}