summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/kqoauth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/kqoauth')
-rw-r--r--dev-libs/kqoauth/Manifest1
-rw-r--r--dev-libs/kqoauth/kqoauth-0.98-r1.ebuild31
-rw-r--r--dev-libs/kqoauth/kqoauth-0.98.ebuild29
-rw-r--r--dev-libs/kqoauth/metadata.xml12
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/kqoauth/Manifest b/dev-libs/kqoauth/Manifest
new file mode 100644
index 000000000000..96b792cd56f9
--- /dev/null
+++ b/dev-libs/kqoauth/Manifest
@@ -0,0 +1 @@
+DIST kqoauth-0.98.tar.gz 37059 SHA256 9d6c43d98bda559cf4fbb055843a46479e08381527a317edcd9823f2b4990671 SHA512 f89e0f046fb7fd7812548f94c460d7c18d4881972e155a99e07503e97fd46b6eada0de9f2c3a94af33ef5b1b3b489bbd5dc6738cee104fe2d11ed62e681c7979 WHIRLPOOL 3a955f7ef9ebd5e5c4e7ff8a6885623ec231a4e8048dced58f480db8063aa854043184ecaa051c1fde8a85d2e8f0aaf1ecd60a98ce05c10f0186dd2d95b76e08
diff --git a/dev-libs/kqoauth/kqoauth-0.98-r1.ebuild b/dev-libs/kqoauth/kqoauth-0.98-r1.ebuild
new file mode 100644
index 000000000000..51ed29588ead
--- /dev/null
+++ b/dev-libs/kqoauth/kqoauth-0.98-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 vcs-snapshot
+
+DESCRIPTION="Library for Qt that implements the OAuth 1.0 authentication specification"
+HOMEPAGE="https://github.com/kypeli/kQOAuth"
+SRC_URI="https://github.com/kypeli/kQOAuth/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # prevent tests from beeing built at src_compile
+ sed -i -e '/SUBDIRS/s/ tests//' ${PN}.pro || die "sed on ${PN}.pro failed"
+ # respect libdir
+ sed -e 's:{INSTALL_PREFIX}/lib:[QT_INSTALL_LIBS]:g' -i src/src.pro || die "sed on src.pro failed"
+
+ qt4-r2_src_prepare
+}
diff --git a/dev-libs/kqoauth/kqoauth-0.98.ebuild b/dev-libs/kqoauth/kqoauth-0.98.ebuild
new file mode 100644
index 000000000000..ba411804d98f
--- /dev/null
+++ b/dev-libs/kqoauth/kqoauth-0.98.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 vcs-snapshot
+
+DESCRIPTION="Library for Qt that implements the OAuth 1.0 authentication specification"
+HOMEPAGE="https://github.com/kypeli/kQOAuth"
+SRC_URI="https://github.com/kypeli/kQOAuth/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # prevent tests from beeing built at src_compile
+ sed -i -e '/SUBDIRS/s/ tests//' ${PN}.pro || die "sed on ${PN}.pro failed"
+
+ qt4-r2_src_prepare
+}
diff --git a/dev-libs/kqoauth/metadata.xml b/dev-libs/kqoauth/metadata.xml
new file mode 100644
index 000000000000..d5189377d9b8
--- /dev/null
+++ b/dev-libs/kqoauth/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>leechcraft</herd>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kypeli/kQOAuth</remote-id>
+ </upstream>
+</pkgmetadata>