summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-01-19 10:17:49 -0500
committerBrian Evans <grknight@gentoo.org>2018-01-19 10:17:49 -0500
commita42f289d6ee90f6598147d1679c069754a9577da (patch)
treefde2fd4b135cc1d71f2a65b42887637687f8fdf1 /dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild
parentdev-util/sysdig: Bump to 0.20.0 (diff)
downloadgentoo-a42f289d6ee90f6598147d1679c069754a9577da.tar.gz
gentoo-a42f289d6ee90f6598147d1679c069754a9577da.tar.bz2
gentoo-a42f289d6ee90f6598147d1679c069754a9577da.zip
dev-libs/legousbtower: Revbump for EAPI and eclass
Previously, it looked in the linux-mod eclass to check KV_MINOR = 4 as it expected 2.x to still be current. Now it uses the modern linux-info eclass and compares with kernel_is Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild')
-rw-r--r--dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild b/dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..f8553d8ef6fb
--- /dev/null
+++ b/dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info
+
+DESCRIPTION="The lego mindstorms usb tower headers and/or modules"
+SRC_URI="mirror://sourceforge/legousb/${P}.tar.gz"
+HOMEPAGE="http://legousb.sourceforge.net/"
+
+SLOT="0"
+LICENSE="MPL-1.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_configure() {
+ if kernel_is -lt 2 5 ; then
+ econf
+ fi
+}
+src_compile()
+{
+ if kernel_is -lt 2 5 ; then
+ emake
+ fi
+}
+
+src_install() {
+ if kernel_is -lt 2 5 ; then
+ einstall
+ else
+ insinto /usr/include/LegoUSB
+ doins include/legousbtower.h
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/20-lego.rules
+ fi
+ dodoc README
+}
+
+pkg_postinst() {
+ if kernel_is -lt 2 5 ; then
+ elog "You are using the 2.4 kernel series."
+ elog "These are unsupported."
+ else
+ elog "You are using the 2.6 kernel series."
+ elog "This package only provides the header file."
+ elog "You need to enable the lego usb tower option in the kernel."
+ fi
+}