summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libnsfb/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libnsfb/files')
-rw-r--r--dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch21
-rw-r--r--dev-libs/libnsfb/files/libnsfb-0.1.2-glibc2.20.patch13
-rw-r--r--dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch19
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch b/dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch
new file mode 100644
index 000000000000..88a776dd85b8
--- /dev/null
+++ b/dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch
@@ -0,0 +1,21 @@
+--- libnsfb-0.1.0/Makefile
++++ libnsfb-0.1.0/Makefile
+@@ -23,10 +23,18 @@
+ NSFB_XCB_PKG_NAMES := xcb xcb-icccm xcb-image xcb-keysyms xcb-atom
+
+ # determine which surface handlers can be compiled based upon avalable library
++ifeq ($(WITH_VNC),yes)
+ $(eval $(call pkg_config_package_available,NSFB_VNC_AVAILABLE,libvncserver))
++endif
++ifeq ($(WITH_SDL),yes)
+ $(eval $(call pkg_config_package_available,NSFB_SDL_AVAILABLE,sdl))
++endif
++ifeq ($(WITH_XCB),yes)
+ $(eval $(call pkg_config_package_available,NSFB_XCB_AVAILABLE,$(NSFB_XCB_PKG_NAMES)))
++endif
++ifeq ($(WITH_WLD),yes)
+ $(eval $(call pkg_config_package_available,NSFB_WLD_AVAILABLE,wayland-client))
++endif
+
+ # surfaces not detectable via pkg-config
+ NSFB_ABLE_AVAILABLE := no
diff --git a/dev-libs/libnsfb/files/libnsfb-0.1.2-glibc2.20.patch b/dev-libs/libnsfb/files/libnsfb-0.1.2-glibc2.20.patch
new file mode 100644
index 000000000000..0900166cc0ee
--- /dev/null
+++ b/dev-libs/libnsfb/files/libnsfb-0.1.2-glibc2.20.patch
@@ -0,0 +1,13 @@
+--- libnsfb-0.1.2/Makefile
++++ libnsfb-0.1.2/Makefile
+@@ -20,8 +20,8 @@
+ # would like these flags but gcc earlier than 4.4 fail
+ #-pedantic -Wno-overlength-strings # For nsglobe.c
+
+-CFLAGS := -g -std=c99 -D_BSD_SOURCE -D_POSIX_C_SOURCE=200112L \
+- -I$(CURDIR)/include/ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS) -Wno-error
++CFLAGS := -g -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200112L \
++ -I$(CURDIR)/include/ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+
+ NSFB_XCB_PKG_NAMES := xcb xcb-icccm xcb-image xcb-keysyms xcb-atom
+
diff --git a/dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch b/dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch
new file mode 100644
index 000000000000..8d6ba888b0f4
--- /dev/null
+++ b/dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch
@@ -0,0 +1,19 @@
+--- libnsfb-0.1.3/Makefile
++++ libnsfb-0.1.3/Makefile
+@@ -15,13 +15,13 @@
+ # Toolchain flags
+ WARNFLAGS := -Wall -Wextra -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+- -Wmissing-declarations -Wnested-externs -Werror
++ -Wmissing-declarations -Wnested-externs
+
+ # would like these flags but gcc earlier than 4.4 fail
+ #-pedantic -Wno-overlength-strings # For nsglobe.c
+
+-CFLAGS := -g -std=c99 -D_BSD_SOURCE -D_POSIX_C_SOURCE=200112L \
+- -I$(CURDIR)/include/ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS) -Wno-error
++CFLAGS := -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200112L \
++ -I$(CURDIR)/include/ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+
+ NSFB_XCB_PKG_NAMES := xcb xcb-icccm xcb-image xcb-keysyms xcb-atom
+