summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-09-27 20:55:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-09-27 20:55:12 -0400
commitb3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b (patch)
treea9cb061dec9c494de197a1e49c243344245b87d0 /dev-libs/libressl/libressl-2.5.0.ebuild
parentvirtual/libc: prioritize uclibc-ng over uclibc (diff)
downloadgentoo-b3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b.tar.gz
gentoo-b3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b.tar.bz2
gentoo-b3bf0c6e8e827c00f9a5e61173b4e4cb2996c62b.zip
dev-libs/libressl: version bumps to 2.3.8, 2.4.3, 2.5.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/libressl/libressl-2.5.0.ebuild')
-rw-r--r--dev-libs/libressl/libressl-2.5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libressl/libressl-2.5.0.ebuild b/dev-libs/libressl/libressl-2.5.0.ebuild
new file mode 100644
index 000000000000..e6602882fd3a
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/39"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}