summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-27 17:02:37 +0000
committerSam James <sam@gentoo.org>2020-12-27 17:53:16 +0000
commite350fb836f6e37b8acfcc62f42a8607ef233065d (patch)
treeb971b21f4d2abf2a45304f60a70f56a46edcf67b /dev-libs/libucl
parentdev-libs/json-c: Remove old (diff)
downloadgentoo-e350fb836f6e37b8acfcc62f42a8607ef233065d.tar.gz
gentoo-e350fb836f6e37b8acfcc62f42a8607ef233065d.tar.bz2
gentoo-e350fb836f6e37b8acfcc62f42a8607ef233065d.zip
dev-libs/libucl: fix lua USE flag
remove calling lua_setup and co. when not with USE lua Closes: https://bugs.gentoo.org/761808 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/18837 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libucl')
-rw-r--r--dev-libs/libucl/libucl-0.8.1-r100.ebuild4
-rw-r--r--dev-libs/libucl/libucl-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/libucl/libucl-0.8.1-r100.ebuild b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
index 66e66cd2dc80..d576b86cdf0e 100644
--- a/dev-libs/libucl/libucl-0.8.1-r100.ebuild
+++ b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
@@ -42,7 +42,7 @@ src_prepare() {
}
src_configure() {
- lua_setup
+ use lua && lua_setup
local myeconfargs=(
"$(use_enable lua)"
@@ -50,6 +50,8 @@ src_configure() {
"$(use_enable sign signatures)"
"$(use_enable urls)"
"$(use_enable utils)"
+ )
+ use lua && myeconfargs+=(
LUA_INCLUDE="$(lua_get_CFLAGS)"
LIB_LIBS="$(lua_get_LIBS)"
)
diff --git a/dev-libs/libucl/libucl-9999.ebuild b/dev-libs/libucl/libucl-9999.ebuild
index 66e66cd2dc80..d576b86cdf0e 100644
--- a/dev-libs/libucl/libucl-9999.ebuild
+++ b/dev-libs/libucl/libucl-9999.ebuild
@@ -42,7 +42,7 @@ src_prepare() {
}
src_configure() {
- lua_setup
+ use lua && lua_setup
local myeconfargs=(
"$(use_enable lua)"
@@ -50,6 +50,8 @@ src_configure() {
"$(use_enable sign signatures)"
"$(use_enable urls)"
"$(use_enable utils)"
+ )
+ use lua && myeconfargs+=(
LUA_INCLUDE="$(lua_get_CFLAGS)"
LIB_LIBS="$(lua_get_LIBS)"
)