summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libucl')
-rw-r--r--dev-libs/libucl/libucl-0.8.1-r100.ebuild4
-rw-r--r--dev-libs/libucl/libucl-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/libucl/libucl-0.8.1-r100.ebuild b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
index 66e66cd2dc80..d576b86cdf0e 100644
--- a/dev-libs/libucl/libucl-0.8.1-r100.ebuild
+++ b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
@@ -42,7 +42,7 @@ src_prepare() {
}
src_configure() {
- lua_setup
+ use lua && lua_setup
local myeconfargs=(
"$(use_enable lua)"
@@ -50,6 +50,8 @@ src_configure() {
"$(use_enable sign signatures)"
"$(use_enable urls)"
"$(use_enable utils)"
+ )
+ use lua && myeconfargs+=(
LUA_INCLUDE="$(lua_get_CFLAGS)"
LIB_LIBS="$(lua_get_LIBS)"
)
diff --git a/dev-libs/libucl/libucl-9999.ebuild b/dev-libs/libucl/libucl-9999.ebuild
index 66e66cd2dc80..d576b86cdf0e 100644
--- a/dev-libs/libucl/libucl-9999.ebuild
+++ b/dev-libs/libucl/libucl-9999.ebuild
@@ -42,7 +42,7 @@ src_prepare() {
}
src_configure() {
- lua_setup
+ use lua && lua_setup
local myeconfargs=(
"$(use_enable lua)"
@@ -50,6 +50,8 @@ src_configure() {
"$(use_enable sign signatures)"
"$(use_enable urls)"
"$(use_enable utils)"
+ )
+ use lua && myeconfargs+=(
LUA_INCLUDE="$(lua_get_CFLAGS)"
LIB_LIBS="$(lua_get_LIBS)"
)