summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-01-13 13:37:27 +0100
committerCraig Andrews <candrews@gentoo.org>2019-01-14 13:51:17 -0500
commit2e29bb29e57ff5256371265b0762a6d2256f2a7a (patch)
tree22288ec87ac43aed39c902283d403ac07630cd4c /dev-libs/spdlog/spdlog-1.3.0.ebuild
parentapp-admin/helm: Version bump to 2.12.2 (diff)
downloadgentoo-2e29bb29e57ff5256371265b0762a6d2256f2a7a.tar.gz
gentoo-2e29bb29e57ff5256371265b0762a6d2256f2a7a.tar.bz2
gentoo-2e29bb29e57ff5256371265b0762a6d2256f2a7a.zip
dev-libs/spdlog: verbump to 1.3.0
Closes: https://bugs.gentoo.org/675366 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog/spdlog-1.3.0.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-1.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/spdlog/spdlog-1.3.0.ebuild b/dev-libs/spdlog/spdlog-1.3.0.ebuild
new file mode 100644
index 000000000000..497e7da9b419
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/libfmt-5.0.0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
+
+src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}