summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-10-12 20:38:34 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-10-12 20:38:34 +0200
commit10942bf83b1eaff5647af5f136793bcb993bd022 (patch)
treea6eeb237a6588a593eb509f7990e6545fd156126 /dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
parentnet-analyzer/prometheus-node_exporter: Fix metadata.xml (diff)
downloadgentoo-10942bf83b1eaff5647af5f136793bcb993bd022.tar.gz
gentoo-10942bf83b1eaff5647af5f136793bcb993bd022.tar.bz2
gentoo-10942bf83b1eaff5647af5f136793bcb993bd022.zip
dev-ml/ocplib-simplex: Add dev-ml/ocplib-simplex-0.3
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild')
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
new file mode 100644
index 000000000000..cf06261cf33b
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools findlib multilib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"usr/"$(get_libdir)"/ocaml
+}