summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-26 13:19:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-26 14:03:10 +0200
commitf03d3633119870c103f63b484335861f64621ad0 (patch)
treeb4c90864f9cfab6765305dc566da31886a833883 /dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
parentdev-ml/alcotest: bump to 0.8.2 (diff)
downloadgentoo-f03d3633119870c103f63b484335861f64621ad0.tar.gz
gentoo-f03d3633119870c103f63b484335861f64621ad0.tar.bz2
gentoo-f03d3633119870c103f63b484335861f64621ad0.zip
dev-ml/opam-file-format: initial import
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild b/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
new file mode 100644
index 000000000000..e932f300db77
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+MY_PV="${PV/_beta/-beta}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake byte $(usex ocamlopt native "")
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
+}