summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-10 14:44:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-11 10:14:07 +0100
commit8b6d66f7ff988333f56d5e45b1e0293adebe64bb (patch)
tree3a403b44b318becf1556f710a6bb60268a468cd4 /dev-ml/opam/opam-1.3.1.ebuild
parentx11-misc/xowl: Fix description. (diff)
downloadgentoo-8b6d66f7ff988333f56d5e45b1e0293adebe64bb.tar.gz
gentoo-8b6d66f7ff988333f56d5e45b1e0293adebe64bb.tar.bz2
gentoo-8b6d66f7ff988333f56d5e45b1e0293adebe64bb.zip
dev-ml/opam: Bump to 1.3.1
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/opam/opam-1.3.1.ebuild')
-rw-r--r--dev-ml/opam/opam-1.3.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/opam/opam-1.3.1.ebuild b/dev-ml/opam/opam-1.3.1.ebuild
new file mode 100644
index 000000000000..10441e2b2ac6
--- /dev/null
+++ b/dev-ml/opam/opam-1.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+DEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-5:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+RDEPEND="${DEPEND}
+ dev-ml/findlib
+"
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}