summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-01-16 10:26:11 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-01-16 10:26:11 +0100
commitb0cfbfbe9b00e137d058434b1d83b50efada1ddd (patch)
treed3d2a130059141f13aaaefc505424cde20c1ead6 /dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
parentdev-ml/calendars: add dep (diff)
downloadgentoo-b0cfbfbe9b00e137d058434b1d83b50efada1ddd.tar.gz
gentoo-b0cfbfbe9b00e137d058434b1d83b50efada1ddd.tar.bz2
gentoo-b0cfbfbe9b00e137d058434b1d83b50efada1ddd.zip
dev-ml/ppx_deriving: remove old version
Closes: https://bugs.gentoo.org/765436 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
deleted file mode 100644
index 5b315e69bee2..000000000000
--- a/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit findlib eutils opam
-
-DESCRIPTION="Type-driven code generation for OCaml"
-HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving"
-SRC_URI="https://github.com/ocaml-ppx/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc +ocamlopt test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-ml/ppx_tools:=
- dev-ml/ocaml-migrate-parsetree:=
- dev-ml/ppx_derivers:=
- dev-ml/result:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${RDEPEND}
- dev-ml/cppo
- test? ( dev-ml/ounit )"
-
-src_compile() {
- cp pkg/META.in pkg/META || die
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
- use doc && emake doc
-}
-
-src_test() {
- ocamlbuild -j 0 -use-ocamlfind -classic-display \
- src_test/test_ppx_deriving.byte -- || die
- if use ocamlopt; then
- ocamlbuild -j 0 -use-ocamlfind -classic-display \
- src_test/test_ppx_deriving.native -- || die
- fi
-}
-
-src_install() {
- opam_src_install
- mv "${ED}/usr/lib/ppx_deriving/ppx_deriving" "${D}/$(ocamlc -where)/ppx_deriving/" || die
-
- use doc && dohtml api.docdir/*
-}