summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:50:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:59 +0200
commit586ea45db00b3a6b789d6f01dc9562f93dfda236 (patch)
tree8e0db00c3d22603173f8fc4c4078288da846d2ad /dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild
parentdev-ml/ppx_expect: Bump to 0.9.0 (diff)
downloadgentoo-586ea45db00b3a6b789d6f01dc9562f93dfda236.tar.gz
gentoo-586ea45db00b3a6b789d6f01dc9562f93dfda236.tar.bz2
gentoo-586ea45db00b3a6b789d6f01dc9562f93dfda236.zip
dev-ml/ppx_fail: bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild b/dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild
new file mode 100644
index 000000000000..8dce73e85a75
--- /dev/null
+++ b/dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Add location to calls to failwiths"
+HOMEPAGE="https://github.com/janestreet/ppx_fail"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}