summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 18:57:07 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commita6be2071cc51482fa7ea936365bf792906c184e3 (patch)
treec1ab31bd444af313055380039adef151b3849278 /dev-ml/ppx_type_conv
parentdev-ml/ppx_sexp_conv: use proper install method (diff)
downloadgentoo-a6be2071cc51482fa7ea936365bf792906c184e3.tar.gz
gentoo-a6be2071cc51482fa7ea936365bf792906c184e3.tar.bz2
gentoo-a6be2071cc51482fa7ea936365bf792906c184e3.zip
dev-ml/ppx_type_conv: use proper install method.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_type_conv')
-rw-r--r--dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild b/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild
index c8a956a358f3..352093921d02 100644
--- a/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild
+++ b/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Support Library for type-driven code generators"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -23,7 +22,22 @@ DEPEND="dev-ml/ppx_tools:=
dev-ml/ppx_optcomp:="
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.md )
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}