summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_type_conv')
-rw-r--r--dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild b/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild
index c8a956a358f3..352093921d02 100644
--- a/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild
+++ b/dev-ml/ppx_type_conv/ppx_type_conv-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Support Library for type-driven code generators"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -23,7 +22,22 @@ DEPEND="dev-ml/ppx_tools:=
dev-ml/ppx_optcomp:="
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.md )
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}