summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-14 00:02:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-14 00:09:34 +0200
commitcf17060c135e0055c350510ab641b337b3d082f2 (patch)
tree51de703461435b810631f95128a861368bd7cebc /dev-ml/sedlex/sedlex-1.99.4.ebuild
parentdev-ml/ocaml-cstruct: bump to 3.1.0 (diff)
downloadgentoo-cf17060c135e0055c350510ab641b337b3d082f2.tar.gz
gentoo-cf17060c135e0055c350510ab641b337b3d082f2.tar.bz2
gentoo-cf17060c135e0055c350510ab641b337b3d082f2.zip
dev-ml/sedlex: bump to 1.99.4
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/sedlex/sedlex-1.99.4.ebuild')
-rw-r--r--dev-ml/sedlex/sedlex-1.99.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/sedlex/sedlex-1.99.4.ebuild b/dev-ml/sedlex/sedlex-1.99.4.ebuild
new file mode 100644
index 000000000000..b2a4d281ef05
--- /dev/null
+++ b/dev-ml/sedlex/sedlex-1.99.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="An OCaml lexer generator for Unicode"
+HOMEPAGE="https://github.com/alainfrisch/sedlex"
+SRC_URI="https://github.com/alainfrisch/sedlex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/gen:=[ocamlopt(+)?]
+ dev-ml/ppx_tools_versioned:=[ocamlopt(+)?]
+ dev-ml/ocaml-migrate-parsetree:=[ocamlopt(+)?]
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake install
+ else
+ emake install_byteonly
+ fi
+ dodoc CHANGES README.md
+}