summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-16 22:11:02 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-16 22:11:38 +1200
commit0e9bbd93b1e69ffb79c076f94b2206fe86210f55 (patch)
tree99f3457be7311fce857ee4e668cddcacc9b0e8a3 /dev-perl
parentsci-physics/yoda: Use HTTPS (diff)
downloadgentoo-0e9bbd93b1e69ffb79c076f94b2206fe86210f55.tar.gz
gentoo-0e9bbd93b1e69ffb79c076f94b2206fe86210f55.tar.bz2
gentoo-0e9bbd93b1e69ffb79c076f94b2206fe86210f55.zip
dev-perl/Font-AFM: -r bump for EAPI7 + fixes
- EAPI7 - Parallel tests - Pull htmldoc for tests as its the easiest source of Helvetica.afm consumed by the test suite. As it stands, no single package seems to be an authoritative way to get this file, and lots of different packages ship their own copy. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild b/dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild
new file mode 100644
index 000000000000..05a0c85a67cc
--- /dev/null
+++ b/dev-perl/Font-AFM/Font-AFM-1.200.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=1.20
+inherit perl-module
+
+DESCRIPTION="Parse Adobe Font Metric files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-text/htmldoc
+ )
+"
+src_test() {
+ METRICS="${EPREFIX}/usr/share/htmldoc/fonts" perl-module_src_test
+}