summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-13 19:44:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-13 21:02:04 +0100
commit052b66de6c2e095baca23986e74c9f4fa91a88e3 (patch)
tree79df132fb7912b90d1d920bed2124fa4bf092ceb /dev-php/webmozart-assert
parentdev-php/xdebug: bump to v2.7.0 RC1 (diff)
downloadgentoo-052b66de6c2e095baca23986e74c9f4fa91a88e3.tar.gz
gentoo-052b66de6c2e095baca23986e74c9f4fa91a88e3.tar.bz2
gentoo-052b66de6c2e095baca23986e74c9f4fa91a88e3.zip
dev-php/webmozart-assert: bump to v1.4.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/webmozart-assert')
-rw-r--r--dev-php/webmozart-assert/Manifest1
-rw-r--r--dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/webmozart-assert/Manifest b/dev-php/webmozart-assert/Manifest
index 4d692acf5454..6519cc55db61 100644
--- a/dev-php/webmozart-assert/Manifest
+++ b/dev-php/webmozart-assert/Manifest
@@ -1 +1,2 @@
DIST webmozart-assert-1.2.0.tar.gz 11866 BLAKE2B 86cb0f299efff9822ea79964153b17337eac3e17a968b5201680186cfb3f6721b2ca561e041e71b304c6d29d227b446f7f52b65d5a6fc490c8535dd4fee0160c SHA512 36bae648cfe5bbd258d738574a820ea3de2e95b59700d556dd5eadbb1657bc09a7e73000e3436d020e060ecd2a99944199795f315a278acbeeea90570b0a4a22
+DIST webmozart-assert-1.4.0.tar.gz 9241 BLAKE2B bbe5d42732c99700f11db6a3a8b6d6753d60b3e6fbfb8412383459199139f31e3ec55e4abee03295adea19c9c48edb0f13a11597b654fdd0de0a7823ed545586 SHA512 1ed2328de800bb98b7c00264009182934006ae146d86aa313f3478b9f3a7e6eed9dee026ed80d18393724840711ecd9891ee34178676470d12cac8124f819309
diff --git a/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
new file mode 100644
index 000000000000..77df9aa06b41
--- /dev/null
+++ b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="${PN/webmozart-//}"
+
+DESCRIPTION="Assertions to validate method input/output with nice error messages"
+HOMEPAGE="https://github.com/webmozart/assert"
+SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/Webmozart/Assert
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}