summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 14:19:13 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 14:19:13 +0100
commit3f862fcbb7a442ac15113ebc9ba5e948ebfb8131 (patch)
tree66bcb8ecaee84cbe562431c61323fe067f57982f /dev-php
parentdev-php/pecl-radius: add PHP 7.4 support (diff)
downloadgentoo-3f862fcbb7a442ac15113ebc9ba5e948ebfb8131.tar.gz
gentoo-3f862fcbb7a442ac15113ebc9ba5e948ebfb8131.tar.bz2
gentoo-3f862fcbb7a442ac15113ebc9ba5e948ebfb8131.zip
dev-php/pecl-ps: add PHP 7.4 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
index ed4909097c9b..816c3d9eec8a 100644
--- a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
@@ -4,12 +4,12 @@
EAPI="7"
PHP_EXT_NAME="ps"
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
# Only really build for >=7.0
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
@@ -22,12 +22,13 @@ DEPEND="
php_targets_php7-1? ( dev-libs/pslib )
php_targets_php7-2? ( dev-libs/pslib )
php_targets_php7-3? ( dev-libs/pslib )
+ php_targets_php7-4? ( dev-libs/pslib )
"
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ps:0[php_targets_php5-6] )"
PHP_EXT_ECONF_ARGS=""
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
@@ -35,7 +36,7 @@ src_prepare() {
}
src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}