summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:26:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:30:29 +0200
commitfe20790bd891fc1d32ed5c2b518d7a1451364677 (patch)
tree669ad6dce2e06ffab905563d4f340219e2822935 /dev-php
parentdev-php/PEAR-Log: bump to v1.13.2 (diff)
downloadgentoo-fe20790bd891fc1d32ed5c2b518d7a1451364677.tar.gz
gentoo-fe20790bd891fc1d32ed5c2b518d7a1451364677.tar.bz2
gentoo-fe20790bd891fc1d32ed5c2b518d7a1451364677.zip
dev-php/libvirt-php: bump to v0.5.5
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/libvirt-php/Manifest1
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-php/libvirt-php/Manifest b/dev-php/libvirt-php/Manifest
index 841d9e16a640..22401cf67144 100644
--- a/dev-php/libvirt-php/Manifest
+++ b/dev-php/libvirt-php/Manifest
@@ -1 +1,2 @@
DIST libvirt-php-0.5.4.tar.gz 780793 BLAKE2B 8bb4577c26cc0ef8f2a0ae813ade7f5fdea9a2a7d70c97cab1033fde21d9a1c27b8c2ad7a8284096e143e955202bb564767b4d7e1a4bb9e15993895adc119288 SHA512 b5b204549e6810668203d1df8404a5cb71f646ae7e01ea223c6e9b9eec9b1f6500cc5bb4559859959d821a213ff992f22a97e4b683da2c683be3732710943487
+DIST libvirt-php-0.5.5.tar.gz 761250 BLAKE2B 9899d2f0e5ea387333decce5071afc81d4160d54ef570dcbe04422dc3e93479ee57520f9bf33a0275ee86cd4b1c87e5a3f7d5118e0cd87658faed44d2ccd4807 SHA512 2ea263561a0bf5d155314e06dcf3c3b5c278640bc5edfa674cdd777cb6d0810bda0492c6cf77a02bc88fb6aa99b0ff1f0cbaeea87ff2e45bff9b5774a2507684
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild
new file mode 100644
index 000000000000..dae081f9be6e
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+PHP_EXT_ECONF_ARGS=()
+
+inherit php-ext-source-r3 autotools
+
+DESCRIPTION="PHP bindings for libvirt"
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xhtml1 )"
+
+RESTRICT="test"
+# ChangeLog and NEWS are empty files
+DOCS=( AUTHORS README )
+# Remove the insane check for pecl-imagick which is only used in examples
+# and is not called upon in any build
+PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
+
+src_unpack() {
+ default
+
+ # create the default modules directory to be able
+ # to use the php-ext-source-r3 eclass to configure/build
+ ln -s src "${S}/modules"
+}
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ eautoreconf
+ done
+}
+
+src_install() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ doins "src/.libs/${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r3_createinifiles
+ einstalldocs
+ if use doc ; then
+ docinto /usr/share/doc/${PF}/html
+ dodoc -r docs/*
+ fi
+}