summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-12 21:46:10 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-12 21:49:59 +0200
commit2ed80a7f342c962ec617d805e04c19e259fc9a8e (patch)
tree3c5b81cc092a7d53adcfb43e6460fbb9f69f6c88 /dev-python/bandit
parentdev-python/bandit: fix prepare calls (diff)
downloadgentoo-2ed80a7f342c962ec617d805e04c19e259fc9a8e.tar.gz
gentoo-2ed80a7f342c962ec617d805e04c19e259fc9a8e.tar.bz2
gentoo-2ed80a7f342c962ec617d805e04c19e259fc9a8e.zip
dev-python/bandit: add 1.7.1
Closes: https://bugs.gentoo.org/812296 Closes: https://bugs.gentoo.org/786645 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 53d4c6bd118c..96c5a71f5342 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.7.0.tar.gz 506225 BLAKE2B 6e2383576b2091ab98757381bfd5915331fc7b08a251e817a6964d963de60b070f7c4dc7958dd366cf95333f4abc157e80433490ab8b923580cb45d855c13092 SHA512 c51af7ab4c667c376a11f142fa35881a776d420bd3ef41421bd29a713e0b56bbf1622e24cd878e24f57594f03d06b7c2b8258fcf34f57e3a68df4200a34becdc
+DIST bandit-1.7.1.tar.gz 503072 BLAKE2B 1e88b662d8dda0d5c1a1fd7ee2eaa1787b8c4952acefb60c347aa98b3534d9ba212229b050dcf717169fb39132ef77d2d92af834392a0bcaa0b9fbc7d2a4804c SHA512 6543bb0f69339a8d970cf0dd1bcec1392057c5c7fbf229fa4f4e6c9d21a39206f1f3fa17509ca2038cd1671d4b57316f92ee053c1beab102e8d20096d10b685d
diff --git a/dev-python/bandit/bandit-1.7.1.ebuild b/dev-python/bandit/bandit-1.7.1.ebuild
new file mode 100644
index 000000000000..5f92de9a3967
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://github.com/PyCQA/bandit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~s390 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" -m stestr init || die
+ "${EPYTHON}" -m stestr run -v || die "Tests failes with ${EPYTHON}"
+}